ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Bulid Autoware from source, ros dependencies error?

asked 2020-09-09 21:53:00 -0600

zjt gravatar image

updated 2020-09-11 03:10:27 -0600

gvdhoorn gravatar image

I am tring to build autoware from source following https://github.com/Autoware-AI/autowa..., and when I execute

rosdep install -y --from-paths src --ignore-src --rosdistro $ROS_DISTRO

I get the following error about ros dependencies:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies:
lanelet2_extension: Cannot locate rosdep definition for [lanelet2_validation]
lanelet_aisan_converter: Cannot locate rosdep definition for [lanelet2_traffic_rules]
mpc_follower: Cannot locate rosdep definition for [qpoases_vendor]

os-ubuntu16.04 ros-kinetic

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-09-11 03:37:37 -0600

sgermanserrano gravatar image

@zjt what version of Autoware are you trying to build?

edit flag offensive delete link more

Comments

According this https://github.com/Autoware-AI/autowa... link, I have tried 1.13 and 1.14, both same error occured.

zjt gravatar image zjt  ( 2020-09-11 05:00:36 -0600 )edit

can you try 1.12? 1.13 and 1.14 are not compatible with ubuntu 16 as shown in the table

sgermanserrano gravatar image sgermanserrano  ( 2020-09-11 09:01:27 -0600 )edit

Question Tools

Stats

Asked: 2020-09-09 21:53:00 -0600

Seen: 402 times

Last updated: Sep 11 '20