How do I configure Octomap to remove walking trails

asked 2020-09-03 22:42:11 -0600

dtzx gravatar image

Hello, I am trying to build a 2D point cloud map using Octomap but I'm having issues with it. I am currently doing it by converting PointCloud2 data from Laserscan, taken from my 2D LIDAR sensor placed at the front of my robot. However, although Octomap helps to merge the scans, whenever someone walks past, there will be a walking trail left behind which does not get cleared.

I have read from a similar question, this, but I still do not understand how and where I can tune the params. Do I tune it in the Octomapserver config file? What exactly am I supposed to change? I tried playing around but maybe i'm doing it wrongly? I am pretty new to ROS and I'm hoping to get some assistance. Thank you!

edit retag flag offensive close merge delete