Ask Your Question
0

catkin tools stopped working with recent update

asked 2020-08-26 02:41:09 -0600

tompe17 gravatar image

I just updated my focal dist and got a new catkin-tools:

Setting up python3-catkin-tools (0.6.1-1)

And now I get:

tompe@philo:~/lrs_ws/src$ catkin build
Traceback (most recent call last):
  File "/usr/bin/catkin", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 3254, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 3237, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 3266, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 584, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 901, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 787, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'trollius' distribution was not found and is required by catkin-tools

Anybody else seeing this? Is there a workaroundor do I have to use catkin_make?

edit retag flag offensive close merge delete

Comments

This is a known issue. See catkin/catkin_tools#594 (later comments).

And #q353113 for a possible work-around.

gvdhoorn gravatar image gvdhoorn  ( 2020-08-26 02:42:36 -0600 )edit

But it worked before the latest update. So something was broken with the Ubuntu update of catkin-tools.

tompe17 gravatar image tompe17  ( 2020-08-26 07:47:00 -0600 )edit

I tried the suggested workaround before posting the question and it did not work.

tompe17 gravatar image tompe17  ( 2020-08-26 07:48:16 -0600 )edit

This is strange. ros2-latest.list containe one line for focal and

deb [arch=amd64,arm64] http://packages.ros.org/ros2/ubuntu bionic main

so I got the wrong version of python3-catkin-tools from bionic. Removing this line and reinstalling the correct version and it works.

tompe17 gravatar image tompe17  ( 2020-08-26 08:01:39 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-08-26 08:07:07 -0600

tompe17 gravatar image

Seems to have been my fault. For some strange reason my ros2-latest.list was:

deb [arch=amd64] http://packages.ros.org/ros2/ubuntu focal main
deb [arch=amd64,arm64] http://packages.ros.org/ros2/ubuntu bionic main

Removing the bionic line and re-installing python3-catkin-tools fixed the problem. I had gotten a later version from bionic installed which caused the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-08-26 02:41:09 -0600

Seen: 759 times

Last updated: Aug 26 '20