/rtabmap/rtabmap: Did not receive data since 5 seconds!

asked 2020-08-17 17:47:49 -0600

MalarJN gravatar image

updated 2020-08-24 22:07:31 -0600

I am trying to run a simulation project using the following commands in an Amazon EC2 Ubuntu instance: Below are the commands I am executing

$ roslaunch turtlebot_gazebo turtlebot_world.launch world_file:=xyz.world gui:=false
$ roslaunch rtabmap_ros demo_turtlebot_mapping.launch simulation:=true
$ roslaunch rtabmap_ros demo_turtlebot_rviz.launch

Note that I am using the default launch files.

However on launching rtabmap using the second command above, I get the following message:

[ WARN] [1597625438.591012809, 1119.702000000]: /rtabmap/rtabmap: Did not receive data since 5 seconds! Make sure the input topics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized ("ntpdate"). If topics are not published at the same rate, you could increase "queue_size" parameter (current=10).
/rtabmap/rtabmap subscribed to (approx sync):
   /camera/rgb/image_raw,
   /camera/depth/image_raw,
   /camera/rgb/camera_info,
   /scan

I do notice that the topics above are not published. I have tried using a different world file with gazebo but in vain.
How would I go about fixing this issue? Changing the queue_size parameter did not help either.

Versions used- Ubuntu 16.04/Ros-Kinetic/Gazebo 7.16/rtabmap 19.6

Edit 1- I upgraded rtabmap to 0.20.3 with the same results

edit retag flag offensive close merge delete

Comments

Indeed, if doing rostopic hz /camera/rgb/image_raw /camera/depth/image_raw /camera/rgb/camera_info /scan outputs nothing, you should fix the turtlebot launch first.

matlabbe gravatar image matlabbe  ( 2020-08-24 18:22:02 -0600 )edit

Dear Dr.Labbe

I reinstalled everything from scratch And just confirmed that the topics are subscribed to. Please see the output below

ubuntu@ip-XXXXXXXX:~$ rostopic hz /camera/rgb/image_raw /camera/depth/image_raw /camera/rgb/camera_info /scan

subscribed to [/camera/rgb/image_raw]

subscribed to [/camera/depth/image_raw]

subscribed to [/camera/rgb/camera_info]

subscribed to [/scan]

WARNING: may be using simulated time

no new messages no new messages no new messages

Please let me know what is the next thing I have to check !!!

MalarJN gravatar image MalarJN  ( 2020-08-24 22:06:00 -0600 )edit

Topics are subscribed but they seem not published by the simulator (no new messages no new messages no new messages). You should get something like this:

rostopic hz /camera/rgb/image_raw /camera/depth/image_raw /camera/rgb/camera_info /scan
subscribed to [/camera/rgb/image_raw]
subscribed to [/camera/depth/image_raw]
subscribed to [/camera/rgb/camera_info]
subscribed to [/scan]
WARNING: may be using simulated time
         topic             rate   min_delta   max_delta   std_dev    window
================================================================
/camera/rgb/image_raw     54.17   0.0         0.05        0.01574    53    
/camera/depth/image_raw   54.17   0.0         0.06        0.01812    53    
/camera/rgb/camera_info   9.574   0.07        0.15        0.02006    53    
/scan                     9.722   0.1         0.12        0.006999   53
matlabbe gravatar image matlabbe  ( 2020-08-25 11:17:24 -0600 )edit

Please let me know how would I publish the topics?

MalarJN gravatar image MalarJN  ( 2020-08-28 16:51:00 -0600 )edit

Maybe there is a problem running Gazebo on your Amazon EC2 Ubuntu instance. You could try to test locally on your computer to see if it is a cmputer problem.

matlabbe gravatar image matlabbe  ( 2020-08-29 11:30:41 -0600 )edit

It works locally. I've tested in on multiple computers. However, it does not work on any Amazon EC2 Ubuntu instance. I've even tried exporting my local VM (The one that works perfectly) to Amazon and creating an instance with that image and it still does not work.

MalarJN gravatar image MalarJN  ( 2020-08-29 12:36:28 -0600 )edit