ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

[ROS2] Failed to load entry point 'launch'

asked 2020-08-10 04:09:29 -0500

lmiller gravatar image

Hi,

I wanted to start my launch file from command line with following command

ros2 launch <pkg_name> <file>

now i got this error:

Failed to load entry point 'launch': cannot import name 'get_typed_value' from 'launch.frontend.type_utils' (/home/lwnmil2/develop_ws/install/launch/lib/python3.8/site-packages/launch/frontend/type_utils.py)
Traceback (most recent call last):
  File "/opt/ros/foxy/bin/ros2", line 11, in <module>
    load_entry_point('ros2cli==0.9.7', 'console_scripts', 'ros2')()
  File "/opt/ros/foxy/lib/python3.8/site-packages/ros2cli/cli.py", line 39, in main
    add_subparsers_on_demand(
  File "/opt/ros/foxy/lib/python3.8/site-packages/ros2cli/command/__init__.py", line 236, in add_subparsers_on_demand
    extension = command_extensions[name]
KeyError: 'launch'

When I open the help of the ros2 command the same error message is shown and there is no entry for the ros2 command:

ros2 -h


    Failed to load entry point 'launch': cannot import name 'get_typed_value' from 'launch.frontend.type_utils' (/home/lwnmil2/develop_ws/install/launch/lib/python3.8/site-packages/launch/frontend/type_utils.py)
usage: ros2 [-h] Call `ros2 <command> -h` for more detailed usage. ...

ros2 is an extensible command-line tool for ROS 2.

optional arguments:
  -h, --help            show this help message and exit

Commands:
  action     Various action related sub-commands
  bag        Various rosbag related sub-commands
  component  Various component related sub-commands
  daemon     Various daemon related sub-commands
  doctor     Check ROS setup and other potential issues
  interface  Show information about ROS interfaces
  lifecycle  Various lifecycle related sub-commands
  multicast  Various multicast related sub-commands
  node       Various node related sub-commands
  param      Various param related sub-commands
  pkg        Various package related sub-commands
  run        Run a package specific executable
  security   Various security related sub-commands
  service    Various service related sub-commands
  topic      Various topic related sub-commands
  wtf        Use `wtf` as alias to `doctor`

  Call `ros2 <command> -h` for more detailed usage.

What is broken on my system? and how can i fix it? I use Ubuntu 20.04 with foxy

edit retag flag offensive close merge delete

Comments

Seeing the same issue, I don't have a package called launch though

it was working previously in my environment before but then stopped and i'm not sure what changed. test is also not being found. I've tried initializing my workspace and packages from scratch but still have the same issue

drewbeller gravatar image drewbeller  ( 2022-02-08 18:12:04 -0500 )edit

@drewbeller Please do not post answers that are not actually answers. I've converted your answer to a comment. If you have a new question, please open a new question. Thanks!

https://wiki.ros.org/Support

jarvisschultz gravatar image jarvisschultz  ( 2022-02-11 08:47:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-08-10 04:21:50 -0500

lmiller gravatar image

I had a package called launch in my develop workspace so ROS had a name conflict I removed it and now it works

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2020-08-10 04:09:29 -0500

Seen: 2,895 times

Last updated: Aug 10 '20