ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0 No such files or Directory in ECLIPSE

asked 2020-08-04 00:42:33 -0500

VIJAYENDRAN gravatar image

I am trying to load the library

I am using Eclipse 4.16.0 and I want ROS libraries to load from Eclipse when i execute the project.

Below is the error i am getting when i execute my Application from ECLIPSE.

/home/ams_user/work/vijay/MyProj/objs/MyApp: error while loading shared libraries: cannot open shared object file: No such file or directory

However, i am successful in loading from Terminal using ldconfig command.

Any setting in eclipse where i can give the library path.. Kindly suggest..

Tried adding below as below :

select Run --> Run configurations... --> C/C++ Application (double click or click on New). Select the correct binary on the main tab (Search project should work when your binary was already built). Then in the environment tab, added

Name : ROS_ROOT Value : /opt/ros/melodic/share/ros

Name : ROS_LIB (Name i chosen) Value : /opt/ros/melodic/lib/ <-- This is where my lib is located.

But unsuccessful

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2020-08-04 03:22:05 -0500

VIJAYENDRAN gravatar image

Solved as below : Right click on the project, --> select the executable file --> select Run --> Run configurations... --> C/C++ Application . Then in the environment tab, add as below :

        Value ⇒/opt/ros/melodic/lib/
edit flag offensive delete link more


Have you seen wiki/IDEs: Eclipse?

gvdhoorn gravatar image gvdhoorn  ( 2020-08-04 03:24:49 -0500 )edit

YES.. Steps are same as per section "5. Running and debugging your executables within Eclipse"..

VIJAYENDRAN gravatar image VIJAYENDRAN  ( 2020-08-04 03:31:34 -0500 )edit

Question Tools



Asked: 2020-08-03 23:52:36 -0500

Seen: 371 times

Last updated: Aug 04 '20