ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

UR3: connection to PC refused

asked 2020-08-03 09:48:24 -0500

Eike2601 gravatar image

Dear all, I'm using ROS melodic on Ubuntu 18.04 with Kernel 5.3.0.59-generic a UR3 Robot.

After a lot of problems by trying to use my UR3 with ROS, I decided today to delete my catkin_ws folder and install everything new.

Now I got a problem, what in my opinion, has nothing to do with this. On friday I was able to connect the UR3 with the PC, now on monday I decided to install everything new (so unfortunally I havn't tested before, if a connection is possible or not) and now I'm no longer able to connect the UR3 with my PC. The computer shows me, that he is connected via Hub to the Robot when I check it via ping 131.246.27.113 in the terminal.

But if I want to run the program externalcontrol on the UR (which worked fine on friday) it shows me:

    The connection to the remote PC could not be established

Then I can stop the program or go on, but it doesn't work both ways.

I tried to connect it without the hub, diretly to the PC's ethernet port, but this doesn't worked as well. I also installed the externalcontrol a second time under a alternating program name, both doesn't work.

I really have no idea what is going on..

Kind Regards Eike

edit retag flag offensive close merge delete

Comments

1

The IP you mention is apparently one from the Technische Universitaet Kaiserslautern and is a public IP.

This seems to suggest you're using the networking infrastructure of the university to connect your ROS PC to your robot.

I would not recommend you do this for various reasons:

  1. the university could have a (or multiple) firewalls between the ROS PC and your robot. That would not be good for performance, nor for ease of use (ports may be blocked, etc)
  2. depending on network utilisation, this could lead to dropped packets, which leads to deteriorated control performance

I tried to connect it without the hub, diretly to the PC's ethernet port, but this doesn't worked as well.

If possible, this would actually be the preferred solution. Or at least, a good one to make sure you have everything working correctly software-wise, without having to diagnose all sorts of network ...(more)

gvdhoorn gravatar image gvdhoorn  ( 2020-08-04 03:12:35 -0500 )edit

Do not use 131.246.27.113 or any IP which starts with 131.246 or similar. Use IPs from the private IP ranges.

Note: if your ROS PC only has a single NIC, you may temporarily lose connection to the internet. That would be expected.

I would recommend to first sort out your network and only then start working on any other issues.

gvdhoorn gravatar image gvdhoorn  ( 2020-08-04 03:15:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-09-02 09:24:28 -0500

Eike2601 gravatar image

updated 2020-09-02 09:25:07 -0500

Well, after installing everything new from scratch, it worked fine. I don't know why, it could be a simple thing as a typo, because I done it the same way as before.

Thanks for your hints gvdhoorn, but now it worked with the hub and the networking infrastructure (my mentor wants me to do it this way, your argumentation against it seems really reasonable to me).

edit flag offensive delete link more

Comments

I'll just repeat my recommendation (for future readers as well): when externally controlling an (industrial) robot over a network connection, especially when it's a form of real-time control, such as is the case with Universal Robots, try to only use a direct network connection between the PC and the robot controller.

Try to avoid introducing any kind of (NAT) router, firewall, hub or switch, and especially don't use a wireless connection between the PC and the robot controller.

The more devices sharing the same network segment(s), the higher the chances will become control performance will be degraded due to collisions and unpredictable network performance.

gvdhoorn gravatar image gvdhoorn  ( 2020-09-02 09:54:47 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2020-08-03 09:48:24 -0500

Seen: 653 times

Last updated: Sep 02 '20