Ask Your Question
3

Using .dae file in gazebo

asked 2012-06-06 06:54:18 -0500

prasanna.kumar gravatar image

updated 2012-06-06 06:54:42 -0500

I am new to gazebo and I am going through the tutorials. I want to model a house in gazebo and spawn TurtleBot in it. I downloaded some furniture models in .obj format from http://www.sweethome3d.com/importModels.jsp. Using "Whoola Collada Converter" I converted .obj files to .dae. Now, How to use these .dae file and spawn the furnitures in gazebo ?

edit retag flag offensive close merge delete

Comments

2

@DimitriProsser: Minutes after posting this question, I myself saw that page. I changed the file name to what I had and ran the urdf file in gazebo and rviz. Gazebo said "Model spawned Succesfully" but nothing actually appeared on the window. It was as empty as before. What could be the problem ?

prasanna.kumar gravatar imageprasanna.kumar ( 2012-06-06 11:33:00 -0500 )edit

Did you include both the <visual> and <collision> tags? Are you spawning the model such that it's in collision with the ground or another object? (This could cause it to sink below the ground)

DimitriProsser gravatar imageDimitriProsser ( 2012-06-06 12:01:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-06-06 07:38:02 -0500

DimitriProsser gravatar image

You're going to have to build a URDF of your building by following these tutorials. In order to use your .dae files, you will need to set them as the mesh for <geometry>.

<link name="left_gripper">
  <visual>
    <geometry>
      <mesh filename="package://pr2_description/meshes/gripper_v0/l_finger.dae"/>
    </geometry>
  </visual>
</link>
edit flag offensive delete link more
0

answered 2012-06-07 04:55:56 -0500

prasanna.kumar gravatar image

updated 2012-06-07 04:56:22 -0500

@DimitriProsser: I did not include anything of what you have mentioned. This is my code

<robot name="table">
  <link name="table">
    <visual>
    <geometry>
           <mesh filename="/home/prasanna/tableBasseBois.dae"/>
        </geometry>
    </visual>
  </link>
</robot>

I saved it as table.urdf and ran it using

rosrun gazebo spawn_model -file /home/prasanna/gazebo_try/table.urdf -urdf -z 1 -model table

I get the message "model spawned successfully" but noting actually appears. This is the only model I have spawned. The model did not sink below either. I checked.

edit flag offensive delete link more

Comments

I am also having these problems. Any solutions to: "I get the message "model spawned successfully" but noting actually appears. This is the only model I have spawned. The model did not sink below either. I checked."

whiterose gravatar imagewhiterose ( 2013-02-20 01:47:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-06 06:54:18 -0500

Seen: 3,228 times

Last updated: Jun 07 '12