Install Kinetic on Ubunut 16.04 - dependencies and broken packages

asked 2020-07-20 11:28:23 -0500

tucker gravatar image

updated 2020-07-21 08:25:07 -0500

Hi, I am trying to install the kinetic base package on Ubuntu 16.04 and having trouble. I've followed the instructions on the install page, but every time I attempt sudo apt-get install ros-kinetic-ros-base, I get an error about numerous unmet dependencies, and then "E: cannot resolve problems, you have held broken packages"

These are all the things I have already tried...

  1. running sudo dpkg --configure -a ;sudo apt-get clean && sudo apt-get update ; sudo apt-get dist-upgrade; ;sudo apt-get install -f
  2. Using synaptic package manager to fix broken packages
  3. sudo apt-get update --fix-missing;sudo dpkg --configure -a;sudo apt-get install -f
  4. If I run dpkg -l | grep ^..r nothing is returned
  5. sudo apt-get remove with the instructions at (editing dpkg status file and deleting lock files)

Nothing seems to be working! Any suggestions?

Edit: Below is the specific error message I get (slightly abridged) when I type in sudo apt-get install ros-kinetic-ros-base If I try to install the full desktop version instead, the specific dependencies it reports that I am missing change, but the structure of the error is the same.

"Some packages could not be installed. This may mean that you have requested an impossible situation ro if you are using the unstale distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-kinetic-ros-base : Depends: ros-kinetic-actionlib but it is not going to be installed ...4 more like these.... E: unable to correct problems, you have held broken packages"

edit retag flag offensive close merge delete


is there any error message about which packages your having trouble with? Is this from ROS or something else you installed prior?

mgruhler gravatar image mgruhler  ( 2020-07-21 02:52:09 -0500 )edit

I edited the original post - the packages are actionlib, bond core, dynamic reconfigure, nodulet core, pluginlib, and roscore. I don't think it has to do with anything previously installed.

tucker gravatar image tucker  ( 2020-07-21 08:27:45 -0500 )edit