Ask Your Question
0

Intel Realsense nodelets running with remote roscore are dying (bond broken)

asked 2020-07-14 15:49:16 -0500

awiley gravatar image

updated 2020-07-15 08:58:53 -0500

Hi, I am having a hard time finding a solution to my issue. Here is my setup.

  • Computer 1 (master computer): roscore, a subscriber that subscribes to a custom msg.
  • Computer 2: "roslaunch realsense2_camera rs_camera.launch", a subscriber that subscribes to a depth topic and publishes our custom msg.

Both computers are running Ubuntu 16.04 with kernel 4.15.0-107-generic.

Both computers are using Kinetic as their ROS version.

And both computers are using realsense SDK version: 2.36.0.

I have set the ROS_MASTER_URI on computer 2 to http://computer1IP:11311, both computers are connected via Ethernet. (following this tutorial)

When I run "roslaunch realsense2_camera rs_camera.launch" on computer 2 this is the error I get:

[ INFO] [1594757854.382965902]: RealSense Node Is Up!
[camera/realsense2_camera-2] process has finished cleanly
log file: /home/<user_name>/.ros/log/e172c1b8-c651-11ea-8aea-00073273924f/camera-realsense2_camera-2*.log

I have tried following the solution here but it does not work for me. It would help out a ton if someone knew how to fix this issue.

Here is the output of env | grep ROS: (If it's helpful)

ROS_ROOT=/opt/ros/kinetic/share/ros    
ROS_PACKAGE_PATH=/home/user_name/catkin_ws/src:/opt/ros/kinetic/share    
ROS_MASTER_URI=http://computer1IP:11311    
ROS_PYTHON_VERSION=2    
ROS_VERSION=1    
ROSLISP_PACKAGE_DIRECTORIES=/home/user_name/catkin_ws/devel/share/common-lisp    
ROS_DISTRO=kinetic    
ROS_IP=localhost
ROS_ETC_DIR=/opt/ros/kinetic/etc/ros

EDIT I found a fix that works so far, I don't know if it's a permanent solution but so far it works.

In my .bashrc on computer 2 I used to have this:

export ROS_MASTER_URI=http://computer1IP:11311
export ROS_IP=localhost

I changed it to:

export ROS_MASTER_URI=http://computer1IP:11311
export ROS_MASTER_URI=computer2IP

I'm not fully sure why using computer2IP instead of localhost fixes it, but my roslaunch no longer gives me the error I was having earlier.

I hope this helps someone and if anyone has a more correct way of doing this please let me know.

edit retag flag offensive close merge delete

Comments

If you feel this is a duplicate, please link to whatever it is a duplicate of.

gvdhoorn gravatar image gvdhoorn  ( 2020-07-16 04:07:39 -0500 )edit

I accidentally marked it as a duplicate question and it wouldn't let me reopen it.

awiley gravatar image awiley  ( 2020-07-16 08:12:24 -0500 )edit

I've re-opened it for you.

gvdhoorn gravatar image gvdhoorn  ( 2020-07-18 03:15:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-08-26 04:29:59 -0500

ashutosh gravatar image

Hi Awiley,

Today I have encountered the same problem. Before adding realsesnecamera in ROS, I was happy with my network by just editing .bashrc and adding the ROS_MASTER_URI and ROS_IP which was creating a working network. Also, did drone flying without any issue but when you add librarealsense ROS wrapper which has nodelet manager which uses service load_nodelet which does not recognize the ROS master. and bond gets broken, after reading the instructions from this solution file. You just need to add exact ip and names in hosts file located in /etc/hosts of both ROS master and jetsontx2, so that realsense nodelet maanger will recognize master properly and this worked for me. You do not need to change ROS_IP as per your suggestion. This is my understandings let me know if something is wrong. Thanks.

edit flag offensive delete link more

Comments

Thank you for your response. All of my stuff is working now, I had done some of those steps the problem was that we were testing more than just 2 computers. This led to some issues with the /etc/hosts and making sure everything was correct. All in all, our stuff works well by setting the ROS_MASTER_URI and ROS_IP so we are happy with our setup.

awiley gravatar image awiley  ( 2020-08-26 09:34:07 -0500 )edit

Happy to know that.

ashutosh gravatar image ashutosh  ( 2020-08-26 09:39:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-07-14 15:49:16 -0500

Seen: 795 times

Last updated: Jul 15 '20