The ~/.bashrc files on both robot and the master machine are set up and sourced. The robot still cannot find the master

asked 2020-07-11 22:06:20 -0600

wcheng3 gravatar image

Hi everyone,

I have the kinetic distro of ROS version 1.12.14 running on my waffle pi model of turtlebot, and the melodic distro of ROS version 1.14.6 running on my master machine. The robot is connected to the same network as the master machine. They can mutually ping each other, and I can also ssh into the robot from the master machine.

I have set up the ~/.bashrc file on my master machine that contains the follows:

export ROS_MASTER_URI=http://192.168.1.5:11311

export ROS_HOSTNAME=192.168.1.5

192.168.1.5 is the IP address of the master machine in the network. And I've sourced the file, sourced the devel/setup.bash file in the catkin_ws folder, and ran the roscore on the master machine. No problem from that side.

On the robot I've set up the ~/.bashrc file that contains the follows:

export ROS_MASTER_URI=http://192.168.1.5:11311

export ROS_IP=192.168.1.7

192.168.1.7 is the IP address of the robot in the network. And I've sourced the file, sourced the devel/setup.bash file in the catkin_ws folder, and ran the following command:

roslaunch turtlebot3_bringup turtlebot3_robot.launch

Then the following error message is displayed from the robot:

ERROR: unable to contact ROS master at [http://192.168.1.5:11311]

A few days ago I was able to make them connect with the above methods as I've done for the past few months, and today when I repeat exactly the same steps, they did not connect anymore but were still able to ping each other. I've redone all the things they said in the manual online and was able to ping mutually from the master machine to the robot and vice versa. The robot still could not recognize the master machine via the roslaunch command...

Can you help me out? Thank you so much!

edit retag flag offensive close merge delete

Comments

I am having the exact same issue currently, it seems to happen when utilising chrony for a time sync on mine. Did you find a solution?

Nicholas.P gravatar image Nicholas.P  ( 2021-01-31 06:49:05 -0600 )edit