Can't load stomp plugin: Moveit

asked 2020-07-09 08:11:58 -0600

miguelnery gravatar image

updated 2022-01-22 16:10:39 -0600

Evgeny gravatar image

Hi everybody. I'm having some troubles to use stomp plugin. I'm using UR5_moveit_config (ros-industrial) and running Ros Melodic, Ubuntu 18.04.

I've already done tutorials and my stomp_planning.yaml move_group.launch and stomp_planning_pipeline.launch.xml files are exactly how they should be.

The strange thing is that some months ago I could use stomp with these same files and it worked. Now I'm trying to configure it again but it keeps showing this error message (It only happens with STOMP, with Chomp and Ompl it worked just fine):

Planning scene monitors started.
[move_group-4] process has died [pid 21517, exit code -11, cmd /opt/ros/melodic/lib/moveit_ros_move_group/move_group --debug __name:=move_group __log:=/home/miguel/.ros/log/b238031e-c1e1-11ea-8fc2-7427ea7d610f/move_group-4.log].
log file: /home/miguel/.ros/log/b238031e-c1e1-11ea-8fc2-7427ea7d610f/move_group-4*.log
[ INFO] [1594298570.839315658]: Stereo is NOT SUPPORTED
[ INFO] [1594298570.839373086]: OpenGl version: 4.4 (GLSL 4.4).
[ INFO] [1594298574.144553094]: Loading robot model 'ur5'...
[ WARN] [1594298574.144597465]: Skipping virtual joint 'fixed_base' because its child frame 'base_link' does not match the URDF frame 'world'
[ INFO] [1594298574.144618802]: No root/virtual joint specified in SRDF. Assuming fixed joint
[ WARN] [1594298574.163315573]: IK plugin for group 'manipulator' relies on deprecated API. Please implement initialize(RobotModel, ...).
[ INFO] [1594298574.165268374]: IK Using joint shoulder_link -6.28319 6.28319
[ INFO] [1594298574.165316412]: IK Using joint upper_arm_link -6.28319 6.28319
[ INFO] [1594298574.165336948]: IK Using joint forearm_link -3.14159 3.14159
[ INFO] [1594298574.165353638]: IK Using joint wrist_1_link -6.28319 6.28319
[ INFO] [1594298574.165370085]: IK Using joint wrist_2_link -6.28319 6.28319
[ INFO] [1594298574.165386402]: IK Using joint wrist_3_link -6.28319 6.28319
[ INFO] [1594298574.165418782]: Looking in common namespaces for param name: manipulator/position_only_ik
[ INFO] [1594298574.166248743]: Looking in common namespaces for param name: manipulator/solve_type
[ INFO] [1594298574.167059766]: Using solve type Distance
[ INFO] [1594298574.204694716]: Starting planning scene monitor
[ INFO] [1594298574.206592611]: Listening to '/move_group/monitored_planning_scene'
[ INFO] [1594298574.388339239]: waitForService: Service [/get_planning_scene] has not been advertised, waiting...
[ INFO] [1594298579.393459485]: Failed to call service get_planning_scene, have you launched move_group or called psm.providePlanningSceneService()?
[ INFO] [1594298579.393707589]: Constructing new MoveGroup connection for group 'manipulator' in namespace ''
[ERROR] [1594298609.399390661]: Unable to connect to move_group action server 'move_group' within allotted time (30s)

I would appreciate any help! Thanks

edit retag flag offensive close merge delete