Ask Your Question
1

Rviz tf error: Failed to transform from frame [/map] to frame [map]

asked 2020-06-23 02:26:53 -0500

ilsta gravatar image

Hi guys,

I have a really strange error with with new set up Ubuntu 20.04 and ROS Noetic. I have a rosbag file which is played and I get an error in RViz at showing a pointcloud: Failed to transform from frame [/map] to frame [map]. On my other computer (Ubuntu 18.04 and ROS Melodic) I have not any problem. In my opinion, there should be now difference between "/map" and "map". Hopefully, somebody have an idea.... Best regards, ilsta

edit retag flag offensive close merge delete

Comments

1

Hi, Did you find a solution for this? I just updated and I have the same problem

patriciaD gravatar image patriciaD  ( 2020-06-29 03:08:14 -0500 )edit

No, I just had to record a new bagfile and I changed in my code/launchfile the frame to "map" and now it works. But former there was no such error/problem at ROS....

ilsta gravatar image ilsta  ( 2020-06-29 03:15:44 -0500 )edit

I have this problem as well. I recorded the bag with Pointcloud2 msg using ROS Kinetic. Then I tried to replay the bag in ROS Noetic and I get same problem (Failed to transform from frame [/world] to frame [world]). What I did to temporary solved it is I changed the fixed frame in RVIZ to "//world" (double slash)

fakhrulzakuan gravatar image fakhrulzakuan  ( 2020-10-17 10:57:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-11-15 09:14:53 -0500

dolphinlove gravatar image

Hi, fakhrulzakuan mentioned a good point, but you can't save the rviz configuration that you need to adjust the frame name every time you use it. So you could simply change the frame_id to "map" instead of "/map" and everything is fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-06-23 02:26:13 -0500

Seen: 955 times

Last updated: Nov 15 '20