Map not loaded in rviz2 when sourced with eloquent

asked 2020-06-22 05:21:49 -0500

Priya gravatar image

updated 2020-06-22 06:43:19 -0500

mgruhler gravatar image

Hello, I tried to follow the below tutorial : with eloquent distro. I tried to generate a map using Cartographer and it was successful. So I went to run the navigation2 in simulation as mentioned in the tutorial and see that the map is not being loaded into the rviz2. I can see that the map files are being loaded:

[map_server-2] [INFO] [map_server]: Loading yaml file: /home/map.yaml
[map_server-2] [INFO] [map_server]: Loading image_file: /home/map.pgm
I see error messages like this :
[planner_server-5] Warning: Invalid frame ID "map" passed to canTransform argument target_frame - frame does not exist
[planner_server-5]          at line 133 in /tmp/binarydeb/ros-eloquent-tf2-0.12.5/src/buffer_core.cpp
[planner_server-5] [ERROR] []: Failed to finish transition 3. Current state is now: active (Could not publish transition: publisher's context is invalid, at /tmp/binarydeb/ros-eloquent-rcl-0.8.4/src/rcl/publisher.c:394, at /tmp/binarydeb/ros-eloquent-rcl-lifecycle-0.8.4/src/rcl_lifecycle.c:344)
[lifecycle_manager-1] [ERROR] [lifecycle_manager]: Failed to change state for node: planner_server
[lifecycle_manager-1] [ERROR] [lifecycle_manager]: Failed to bring up nodes: aborting bringup
[lifecycle_manager-1] terminate called after throwing an instance of 'rclcpp::exceptions::RCLError'

I tried to debug it for sometime now and then I tried to switch my version to dashing. And now everything works. I tried loading the same map that I had generated earlier in eloquent and it worked in dashing. I am still unclear of what happened. Could you please guide me on what was lacked when I tried to use eloquent ?

Please let me know if you need further info. Thank you in advance.

edit retag flag offensive close merge delete