issues installing ros2 foxy fitzroy on macos 10.15

asked 2020-06-20 23:01:13 -0500

devon gravatar image

I'm new to ROS, and trying to get up and running using these instructions:

  1. I've installed the system dependencies globally using homebrew
  2. I've installed the python dependencies in a Python virtual environment
  3. I did not disable SIP because I didn't feel comfortable doing this without understanding the implications. Reading #409 and #457 it sounds like some things might work and others won't, so I don't know if SIP causing the issues
  4. I performed the "Get the ROS 2 code" step which populated ~/ros2_foxy/src
  5. I did not install additional DDS vendors
  6. I tried running colcon build --symlink-install which began populating build, install, and log:

This resulted in:

Summary: 73 packages finished [12min 59s]
  1 package failed: rcutils
  3 packages aborted: ament_index_cpp fastrtps orocos_kdl
  5 packages had stderr output: foonathan_memory_vendor libyaml_vendor rcutils uncrustify_vendor yaml_cpp_vendor
  224 packages not processed

The error related to rcutils was:

--- stderr: rcutils
CMake Error at /usr/local/Cellar/cmake/3.17.3/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:164 (message):
  Could NOT find PythonExtra (missing: PythonExtra_LIBRARIES)
Call Stack (most recent call first):
  /usr/local/Cellar/cmake/3.17.3/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:445 (_FPHSA_FAILURE_MESSAGE)
  /Users/d/ros2_foxy/install/python_cmake_module/share/python_cmake_module/cmake/Modules/FindPythonExtra.cmake:216 (find_package_handle_standard_args)
  /Users/d/ros2_foxy/install/launch_testing_ament_cmake/share/launch_testing_ament_cmake/cmake/launch_testing_ament_cmake-extras.cmake:18 (find_package)
  /Users/d/ros2_foxy/install/launch_testing_ament_cmake/share/launch_testing_ament_cmake/cmake/launch_testing_ament_cmakeConfig.cmake:41 (include)
  /Users/d/ros2_foxy/install/ament_lint_auto/share/ament_lint_auto/cmake/ament_lint_auto_find_test_dependencies.cmake:36 (find_package)
  CMakeLists.txt:128 (ament_lint_auto_find_test_dependencies)

It sounds from this error like some Python dependency might be missing, but it's not clear to me which one.

After this, I tried running running the environment setup. I tried this in bash (normally I run fish):

bash-5.0$ . ~/ros2_foxy/install/setup.bash 
bash-5.0$ which ros2
bash-5.0$ ros2
bash: ros2: command not found

I'm not sure where the ros2 command is supposed to be located. Inspecting setup.bash it doesn't seem to modify my $PATH, and searching for this name only turns up the directory ./src/ros2:

bash-5.0$ ls
build       install     log     ros2.repos  src
bash-5.0$ find . -name ros2
./src/ros2

Thank you for any assistance!

At this point I'll try installing on an Ubuntu machine instead, but I was really hoping to be able to develop using my mac.

edit retag flag offensive close merge delete

Comments

You can always try, but this is stated at the top of the page you link to (under System requirements):

We support macOS 10.14 (Mojave).

you seem to be trying to do this on 10.15, which is not supported at the moment.

gvdhoorn gravatar image gvdhoorn  ( 2020-06-21 03:53:10 -0500 )edit

I didn't notice that, thanks for pointing it out.

devon gravatar image devon  ( 2020-06-21 03:56:41 -0500 )edit