Ask Your Question
0

ROS package not found after catkin_make

asked 2020-06-14 05:54:59 -0500

creazy gravatar image

Hello :)

I'm quite new to ROS and tried to install a package (laser_line_extraction) from github. I completely followed this instruction https://wiki.nps.edu/display/RC/Setti... step-by-step. But after creating the package with catkin it's there as a directory but can't be found with "rospack find ...".

[rospack] Error: package 'laser_line_extraction' not found

Online I found something about "sourcing the launchfile" but no explanation on what this means or how to do it.

Can anyone help?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2020-06-14 06:25:55 -0500

xibeisiber gravatar image

If the package was compiled successfully, try “source ~/.bashrc" or "source /path-ws/devel/setup.bash" and then "rospack find" again

edit flag offensive delete link more

Comments

Thanks, it's working now! :)

creazy gravatar image creazy  ( 2020-06-15 15:14:31 -0500 )edit

@creazy If this answer solved your problem then please mark it as the correct answer by clicking on the check mark that's to the left of the answer

jayess gravatar image jayess  ( 2020-07-09 17:39:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-06-14 05:54:59 -0500

Seen: 72 times

Last updated: Jun 14