Ask Your Question
0

No OpenGL or Nvidia in the docker

asked 2020-06-12 07:01:03 -0500

Mike_Auto gravatar image

I tried to install the latest Autoware.auto in Ubuntu 18.04. I have Nvidia drivers and docker installed, I can run nvidia-smi and glxgears in the host but not in the ADE. Rviz2 cannot start due to wrong OpenGL context. Can anyone tell me how to add the OpenGL and Nvidia support into the docker images? Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2020-06-12 15:28:32 -0500

Josh Whitley gravatar image

By default, we now disable GPU passthrough support in the standard .aderc file. This is because if you have an Nvidia GPU but don't have nvidia-container-toolkit installed, you will get errors as well. To use Nvidia GPU passthrough, you'll need to install nvidia-container-toolkit using the instructions here. After that, modify your .aderc file and remove the line export ADE_DISABLE_NVIDIA_DOCKER=true to re-enable Nvidia GPU passthrough.

Note: The .aderc-lgsvl file does not have this line because LGSVL requires an Nvidia GPU with GPU passthrough enabled.

edit flag offensive delete link more

Comments

There is also an ongoing discussion about this in this issue.

Josh Whitley gravatar image Josh Whitley  ( 2020-06-16 13:47:36 -0500 )edit
1

This helped me while following the lgsvl tutorial for Autoware.Auto: https://www.lgsvlsimulator.com/docs/a... Thank you very much.

LennartL gravatar image LennartL  ( 2020-08-18 03:03:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-06-12 07:01:03 -0500

Seen: 505 times

Last updated: Jun 12 '20