Ask Your Question
0

No autoware.ai folder, when launching autoware in Docker

asked 2020-06-10 17:44:02 -0500

chris909 gravatar image

updated 2020-06-11 09:07:38 -0500

Hey, guys,

when running autoware after first installation from docker, no autoware folder is found, do you have any clues?

proceeding every steps with the latest guides, until :'

cd autoware.ai '

Docker is successfully installed with Ubuntu 18.04 and launching with tag cuda off.


update

only folder 'Autoware' and 'shared_dir' exist

autoware@w-VirtualBox:~$ ls Autoware shared_dir


Terminal

w@w-VirtualBox:~$ sudo docker run hello-world

... Hello from Docker! ...

w@w-VirtualBox:~$ git clone https://gitlab.com/autowarefoundation... Cloning into 'docker'... remote: Enumerating objects: 124, done. remote: Counting objects: 100% (124/124), done.

remote: Compressing objects: 100% (81/81), done. remote: Total 625 (delta 66), reused 93 (delta 43), pack-reused 501 Receiving objects: 100% (625/625), 987.21 KiB | 4.33 MiB/s, done. Resolving deltas: 100% (280/280), done. w@w-VirtualBox:~$ cd docker/generic

w@w-VirtualBox:~/docker/generic$ sudo ./run.sh -s --cuda off

[sudo] password for w: Using options: ROS distro: melodic Image name: autoware/autoware Tag prefix: latest Cuda support: off Pre-release version: off UID: <1000> Launching autoware/autoware:latest-melodic To run a command as administrator (user "root"), use "sudo <command>". See "man sudo_root" for details.

autoware@w-VirtualBox:~$ cd autoware.ai bash: cd: autoware.ai: No such file or directory

edit retag flag offensive close merge delete

Comments

What shows up if you ls in the Docker container?

Also, FYI - launching the container using sudo is not our typical setup. We assume that people have followed the Post-Installation Steps for Linux after install to allow them to run Docker commands as a non-root user.

Josh Whitley gravatar image Josh Whitley  ( 2020-06-11 02:50:05 -0500 )edit

if ls, only "Autoware" and "shared_dir" exist, but no autoware.ai,

autoware@w-VirtualBox:~$ ls Autoware shared_dir

thanks for the user group information, I add it, but still have no clue on the unfound directory.

chris909 gravatar image chris909  ( 2020-06-11 03:59:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-06-11 14:35:17 -0500

Josh Whitley gravatar image

Most of the tutorials are written assuming you're building from source. In the from-source build instructions, we have you create a folder called autoware.ai to use as your workspace. In the Docker, containers, however, the workspace folder has always been called Autoware. This is a discontinuity but it was a decision between changing an existing pattern to match a new one or keeping what is expected by existing users. We chose the latter. So, if you follow any tutorials using Docker, just replace autoware.ai in the path with Autoware

If you would like this changed, feel free to submit an issue at https://gitlab.com/autowarefoundation....

edit flag offensive delete link more

Comments

thank you, after cd to "Autoware", it can be launched right now.

chris909 gravatar image chris909  ( 2020-06-12 09:15:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-06-10 17:44:02 -0500

Seen: 176 times

Last updated: Jun 11 '20