Ask Your Question
0

ROS2 Eloquent installation failed in Ubuntu 18.04.4 LTS

asked 2020-06-10 02:24:51 -0600

albertleng gravatar image

Referring to link:https://index.ros.org/doc/ros2/Installation/Eloquent/Linux-Install-Debians/ I am installing ROS2 Eloquent into my Ubuntu 18.04.4 LTS.

My system's information is as below (via uname -a)

Linux myname 5.3.0-28-generic #30~18.04.1-Ubuntu SMP Fri Jan 17 06:14:09 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

I could Setup Locale and Setup Sources with no issue. Then, it came to Install ROS 2 packages.

Running sudo apt update gave me:

Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://archive.canonical.com/ubuntu bionic InRelease                     
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease        
Hit:5 http://packages.ros.org/ros2/ubuntu bionic InRelease               
Hit:6 http://archive.ubuntu.com/ubuntu bionic-security InRelease         
Reading package lists... Done                      
Building dependency tree       
Reading state information... Done
234 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://packages.ros.org/ros2/ubuntu bionic InRelease' doesn't support architecture 'i386'

What does the last error message mean? How do I resolve this?

Then, I ran sudo apt install ros-eloquent-desktop and it returned:

  The following packages will be upgraded:
    cpp-7 g++-7 gcc-7 gcc-7-base libasan4 libcilkrts5 libdrm-amdgpu1
  libdrm-common libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libexif12
  libgcc-7-dev libglib2.0-0 libglib2.0-bin libicu60 libjpeg-turbo8 libjson-c3
  libopenexr22 libpython2.7 libpython2.7-minimal libpython2.7-stdlib
  libpython3.6 libpython3.6-minimal libpython3.6-stdlib libsqlite3-0 libssl1.1
  libstdc++-7-dev libubsan0 libuuid1 libwayland-client0 libwayland-cursor0
  libwayland-egl1 libwayland-server0 libxml2 python3.6 python3.6-minimal
38 upgraded, 881 newly installed, 0 to remove and 196 not upgraded.
    Need to get 9,381 kB/432 MB of archives.
    After this operation, 1,967 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Ign:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 gcc-7 amd64 7.5.0-3ubuntu1~18.04
    Err:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 gcc-7 amd64 7.5.0-3ubuntu1~18.04
      Connection failed [IP: 91.189.88.152 80]
    E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gcc-7/gcc-7_7.5.0-3ubuntu1~18.04_amd64.deb  Connection failed [IP: 91.189.88.152 80]
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I truncated the response to only keep the last part which I think will help you to know what's wrong. I googled but could not find the solution. I don't have any firewall and antivirus installed as well.

Please help. Thanks a lot.

edit retag flag offensive close merge delete

Comments

After running sudo dpkg --remove-architecture i386, the message N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://packages.ros.org/ros2/ubuntu bionic InRelease' doesn't support architecture 'i386' is not displayed anymore.

I am still stuck with sudo apt install ros-eloquent-desktop . The same error message still appears.

Any help is deeply appreciated. Have been stuck for few hours. Thanks.

albertleng gravatar image albertleng  ( 2020-06-10 07:38:38 -0600 )edit

1 Answer

Sort by ┬╗ oldest newest most voted
0

answered 2020-06-15 10:07:27 -0600

rwu gravatar image
  • check your sourse list:

    cd /etc/apt/sources.list.d

    grep ros * | grep -v amd64

probably you will see ros2-latest.list:deb http://packages.ros.org/ros2/ubuntu bionic main

edit flag offensive delete link more

Comments

Thanks rwu for the answer.

I have actually resolved my issue but I think your way is more proper. It can serve as my remedy if I encounter similar issue in future. Anyway, what I did was:

I ended up downloading the deb package directly from http://security.ubuntu.com/ubuntu/poo... followed by installing it via the commands (ref: https://unix.stackexchange.com/questi...)

sudo dpkg -i path_to_the_deb
sudo apt --fix-broken install
sudo apt update

Then, I was able to install ros-eloquent-desktop.

albertleng gravatar image albertleng  ( 2020-06-15 21:11:05 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-06-10 02:24:51 -0600

Seen: 558 times

Last updated: Jun 15 '20