"ERROR: cannot download default sources list ... Website may be down.

asked 2020-06-09 15:09:45 -0500

updated 2020-06-10 01:02:23 -0500

gvdhoorn gravatar image

Hi, On CentOS 6.4 (i know) python3.8, on "rosdep init" I am getting:

"ERROR: cannot download default sources list from:
https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
Website may be down.

Looked over the internet, apparently its certificate issue that need to be installed manually? But thats not clear to me how to do it. I've already did "yum install ca-certificates". I am using CentOS on virtual machine, without proxy. I can browse website fine, the link does open in browser.

Also, this is what I get with :

$ wget https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
--2020-06-10 01:04:20--  https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
Resolving raw.githubusercontent.com... 151.101.120.133
Connecting to raw.githubusercontent.com|151.101.120.133|:443... connected.
ERROR: certificate common name “www.github.com” doesn’t match requested host name “raw.githubusercontent.com”.
To connect to raw.githubusercontent.com insecurely, use ‘--no-check-certificate’.

Thank you.

edit retag flag offensive close merge delete

Comments

This does not appear to be an issue with rosdep, but with the way your host verifies SSL certificates and how that is configured.

You'll want to find support for this question somewhere else, as this is not a ROS issue -- as is made clear by the output of wget.

gvdhoorn gravatar image gvdhoorn  ( 2020-06-10 01:03:39 -0500 )edit

Hi, Thank you for your reply and editing the post, and being tolerant with not following the posting guidelines (being new here).

I was trying to install it on CentOS 6.4 virtual machine. What did you mean by host?

I solved the problem by fetching certificate:

openssl s_client -showcerts -servername raw.githubusercontent.com -connect raw.githubusercontent.com:443 </dev/null 2>/dev/null | sed -n -e '/BEGIN\ CERTIFICATE/,/END\ CERTIFICATE/ p' > raw-githubusercontent-com.pem

copying the resulting "raw-githubusercontent-com.pem" to: /usr/share/pki/ca-trust-source/anchors

running: update-ca-trust

obtaining cafile path: python3 -c 'import certifi; print(certifi.where())'

and finally setting SSL_CERT_FILE to that cafile path: export SSL_CERT_FILE=[ca file path here]

speedbooster gravatar image speedbooster  ( 2020-06-10 05:05:08 -0500 )edit

With "host" I meant the OS on which you are running wget and rosdep. So in your case: CentOS 6.4.

From the rest of your comment it would appear indeed to have been a problem with missing certificates.

It could be that a root certificate for the Github certificate is missing on your system, leading ultimately to the certificate not being trusted by your system. By importing the certificate itself, you avoid that.

gvdhoorn gravatar image gvdhoorn  ( 2020-06-10 05:49:21 -0500 )edit