Ask Your Question
0

Win10 WSL: cannot locate certain package plotjuggler

asked 2020-06-09 09:48:30 -0500

Hi,

I'm working on ROS with an Win10 WSL, which is Ubuntu 20.04 LTS.

I successfully install the ros-noetic-desktop-full but the plotjuggler is missing.

The apt failed to locate this package There is ros-noetic-plotjuggler-msg but no ros-noetic-plotjuggler

phoenix@DESKTOP-2IECK0J:~$ sudo apt list | grep ros-noetic | wc

692 2310 53767

phoenix@DESKTOP-2IECK0J:~$ sudo apt list | grep ros-noetic-plotjuggler |wc

1 3 69

phoenix@DESKTOP-2IECK0J:~$ sudo apt list | grep ros-noetic-plotjuggler

ros-noetic-plotjuggler-msgs/focal 0.1.1-1focal.20200529.060406 amd64

phoenix@DESKTOP-2IECK0J:~$ sudo apt install ros-noetic-plotjuggler

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package ros-noetic-plotjuggler

I checked the distro https://github.com/facontidavide/plot... there should be a plotjuggler release for noetic.

the apt update also hits the http://packages.ros.org/ros/ubuntu focal InRelease

Is there anything I missed?

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-06-09 12:06:22 -0500

gvdhoorn gravatar image

According to status_page/ros_noetic_default.html?q=plot, PlotJuggler is indeed not building for Noetic, amd64.

And Nbin_uF64__plotjuggler__ubuntu_focal_amd64__binary (the release job) also doesn't seem to succeed.

You'd have to ask the maintainer why things don't build.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-06-09 09:48:30 -0500

Seen: 28 times

Last updated: Jun 09