ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Noetic released but still not working on Buster

asked 2020-06-02 07:05:59 -0500

Alessandro Melino gravatar image

Hello everyone.

I was noticed that Noetic was at last released for Debian buster the last 23th of May, but when I try to install it the same error occurs:

pi@raspberrypi:~ $ sudo apt install ros-noetic-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-noetic-desktop-full

Does anyone know something? It can be about the change of name from Raspbian Buster to Raspberry Pi OS?

Best regards. Alessandro

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2020-06-02 10:52:12 -0500

gvdhoorn gravatar image

updated 2020-06-03 02:53:03 -0500

This would appear to be (almost) a duplicate of #q353123 (and #q353145).

Buster only gets amd64 and arm64 packages.

I haven't checked, but it's more than likely that Raspbian is still not 64 bit, so there aren't any binaries available for your platform.

Edit: just noticed: #q350055 is your own question, and in my edit there I also mentioned the fact that only arm64 and amd64 get binary packages.

edit flag offensive delete link more


So the only solution is try to install an image of Debian of 64 bits, right?

Alessandro Melino gravatar image Alessandro Melino  ( 2020-06-03 05:29:34 -0500 )edit

answered 2020-06-02 09:06:01 -0500

Reamees gravatar image

Just tried it with the debian:buster docker image and the steps in the install tutorial seemed to work fine (excluding some extra steps required due to the minimal nature of the image). Followed it through to point 1.5. Did you update the apt sources before trying to reinstall? Try sudo apt update before sudo apt install ros-noetic-desktop-full.

edit flag offensive delete link more


Hello, thanks for your answer.

Yes I have update the sources. It seems to be problem of the version of the OS. So, how can I install the image from docker? Because wait to a release of ROS for the new version of Raspberry Pi OS is not an option...

Alessandro Melino gravatar image Alessandro Melino  ( 2020-06-02 10:42:36 -0500 )edit

Question Tools

1 follower


Asked: 2020-06-02 07:05:59 -0500

Seen: 1,006 times

Last updated: Jun 03 '20