Ask Your Question
0

ROS2 building on Windows 10 Could NOT find TinyXML2 (missing: TINYXML2_LIBRARY TINYXML2_INCLUDE_DIR)

asked 2020-05-31 00:43:24 -0500

I am receiving the following error:

CMake Error at C:/Program Files/CMake/share/cmake-3.17/Modules/FindPackageHandleStandardArgs.cmake:164 (message):
  Could NOT find TinyXML2 (missing: TINYXML2_LIBRARY TINYXML2_INCLUDE_DIR)
Call Stack (most recent call first):
  C:/Program Files/CMake/share/cmake-3.17/Modules/FindPackageHandleStandardArgs.cmake:445 (_FPHSA_FAILURE_MESSAGE)
  cmake/Modules/FindTinyXML2.cmake:24 (find_package_handle_standard_args)
  CMakeLists.txt:6 (find_package)

I am tracking this down and have found a couple of interesting things. One of these me to the the Troubleshooting section https://index.ros.org/doc/ros2/Troubleshooting/#windows-troubleshooting, which states:

CMake packages unable to find asio, tinyxml2, tinyxml, eigen, or log4cxx¶ We’ve seen that sometimes the chocolatey packages for asio, tinyxml2, etc. do not add important registry entries and CMake will be unable to find them when building ROS 2. We’ve not yet been able to identify the root cause, but uninstalling the chocolatey packages (with -n if the uninstall fails the first time), and then reinstalling them will fix the issue.

I have tried the above and a ton of other things: Setting ENV vars, changing the *.in files, and some more shots in the dark.

Thought that maybe it was picking up the wrong python, as visual studio has it's own version laying around. As per the instruction, I did install python 3.7.5 in c:\Python37, updated that PATH, and verified with the following:

C:\dev\ros2_eloquent>python --version
Python 3.7.5

Not really sure of what the next step is.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-05-31 17:06:40 -0500

flynneva gravatar image

If you're building from source I'd recommend upgrading to Foxy. I've seen this issue before with windows and it was due to incorrect environment variables for me....but you said that you've checked that so maybe an upgrade would help?

edit flag offensive delete link more

Comments

Which ENVs. Not sure I got all of the ones I planned on. I just dumped eloquent and pulled foxy. Got the same error. Pretty sure it is something stupid I thought I didn't, but didn't.

pulcher gravatar image pulcher  ( 2020-06-02 21:14:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-05-31 00:43:24 -0500

Seen: 17 times

Last updated: May 31