Ask Your Question
0

How to use ft_sensor plugin in ROS-Noetic?

asked 2020-05-27 12:56:17 -0500

mkb_10062949 gravatar image

Hello I have a urdf with a ft_sensor plugin attached and which works fine in ros-melodic with ubuntu 18.04. The plugin in the urdf looks like,

  <!-- Gazebo FT sensor plugin -->

  <gazebo reference="wrist_3_joint">
    <provideFeedback>true</provideFeedback>
  </gazebo>
  <gazebo>
    <plugin name="ft_sensor_plugin" filename="libgazebo_ros_ft_sensor.so">
      <updateRate>200</updateRate>
      <topicName>ft_sensor/raw</topicName>
      <gaussianNoise>0.0</gaussianNoise>
      <jointName>wrist_3_joint</jointName>
    </plugin>
  </gazebo>

Now I have switched to ROS - Noetic with Ubuntu 20.04. I referred the path /opt/ros/noetic/lib where I found the file libforce_torque_sensor_controller.so. So I modified my plugin as,

  <!-- Gazebo FT sensor plugin -->

  <gazebo reference="wrist_3_joint">
    <provideFeedback>true</provideFeedback>
  </gazebo>
  <gazebo>
    <plugin name="ft_sensor_plugin" filename="libforce_torque_sensor_controller.so">
      <updateRate>200</updateRate>
      <topicName>ft_sensor/raw</topicName>
      <gaussianNoise>0.0</gaussianNoise>
      <jointName>wrist_3_joint</jointName>
    </plugin>
  </gazebo>

but after launch the launch file I cannot see the topic ft_sensor/raw being published. I have no idea what is the issue here. Please provide your suggestion here.

edit retag flag offensive close merge delete

Comments

Did you know the solution? I also have such an issue.

peng cheng gravatar image peng cheng  ( 2021-05-22 15:42:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-06-03 11:40:02 -0500

sloretz gravatar image

The Gazebo force/torque sensor plugin is provided by the package gazebo_plugins in the gazebo_ros_pkgs repository. The plugin library is called gazebo_ros_ft_sensor, which means the file name Gazebo expects is libgazebo_ros_ft_sensor.so. I don't know where libforce_torque_sensor_controller.so comes from, but I'm certain the solution will not involve changing the filename attribute. Change it back to libgazebo_ros_ft_sensor.so.

First, make sure ros-noetic-gazebo-plugins is installed. May as well install all of gazebo_ros_pkgs:

apt install ros-noetic-gazebo-ros-pkgs

Otherwise, if you're using empty_world.launch then set verbose:=true to see what error Gazebo gives.

https://answers.gazebosim.org//questi... http://gazebosim.org/tutorials/?tut=r...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-05-27 12:56:17 -0500

Seen: 319 times

Last updated: Jun 03 '20