ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

joint_state_publisher_gui not working as per directed

asked 2020-05-14 20:26:09 -0500

ghor96 gravatar image

updated 2022-05-23 09:57:55 -0500

lucasw gravatar image

I made that change in the package.xml file as per instructions on http://wiki.ros.org/joint_state_publi....

I have a new error with catkin_make now:

Error(s): - The manifest of package "rrbot_description" (with format version 1) must not contain the following tags: exec_depend - Either update to a newer format or replace <exec_depend> tags with <run_depend> tags.

So I did run catkin_make with <run_depend> tags instead, which was successful. But while running launching my package I got this error:

When running the tutorial this error still occurs

[joint_state_publisher-1] process has died [pid 25607, exit code 1, cmd /opt/ros/melodic/lib/joint_state_publisher/joint_state_publisher __name:=joint_state_publisher __log:=/home/mirlab/.ros/log/e61c3a20-9648-11ea-8dee-40a5ef0c9aee/joint_state_publisher-1.log]. log file: /home/mirlab/.ros/log/e61c3a20-9648-11ea-8dee-40a5ef0c9aee/joint_state_publisher-1*.log

I have installed the ros-melodic-joint-state-publisher-gui via sudo apt-get install.

My background is ME so please mind my newbie errors.

Any insight on how do I resolve this?

edit retag flag offensive close merge delete

Comments

1

So the joint_state_publisher is deprecated as of early 2020.

No, it's not. It's fully supported.

Could you clarify where you've read/found/heard this?

gvdhoorn gravatar image gvdhoorn  ( 2020-05-15 06:11:07 -0500 )edit

http://wiki.ros.org/joint_state_publi...

I misinterpreted that as deprecated. I have made the change to my question.

ghor96 gravatar image ghor96  ( 2020-05-15 10:08:36 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-05-15 06:12:44 -0500

gvdhoorn gravatar image

updated 2020-05-15 06:12:57 -0500

To make the new joint_state_publisher_gui work I followed the instructions of adding <exec_depend>joint_state_publisher_gui<exec_depend> to the package.xml. This gives me an error while running catkin_make

    Error(s) in package '/home/mirlab/catkin_ws/src/gazebo_ros_demos/rrbot_description/package.xml':
    The manifest contains invalid XML:
    mismatched tag: line 25, column 2

You've not closed the <exec_depend> tag correctly.

The second <exec_depend> is missing the forward-slash, it should be: </exec_depend>.

edit flag offensive delete link more

Comments

So I made that change in the package.xml file

I have a new error with catkin_make now:

I updated my question to reflect the current status.

ghor96 gravatar image ghor96  ( 2020-05-15 10:22:26 -0500 )edit

Question Tools

Stats

Asked: 2020-05-14 20:26:09 -0500

Seen: 648 times

Last updated: May 15 '20