Ask Your Question
0

Ros with Labview: can see topics but no data

asked 2020-05-13 03:34:58 -0500

Lol gravatar image

Hello everybody, I've got a ROS node running on Labview on my PC (Windows 10, 192.168.1.129). It is publishing some data on a topic. ROS is installed on a Raspberry Pi 3 with Ubuntu SO (18.04, IP: 192.168.1.130). I don't have ROS installed on Windows, so obviously the master is running on Raspberry PI 3. So my PC and Raspberry Pi are connected to the same network, and can communicate through ssh. If I ping each other, it works. But then, when I run the Publisher on Labview (on Windows), I mean when I run the node that publishes on a topic, from Ubuntu terminal I can see the topic, with “rostopic list”, but then with “rostopic echo” I can’t see anything. So then I try to ping the node publishing on Labview with “rosnode ping”, but it says: “ERROR: Communication with node[http://169.254.201.168:50436] failed!”. I’ve already done everything they say in other similar questions, I’ve edited the etc/host file on my PC adding the Ubuntu hostname and IP, and I’ve done the same on Ubuntu, adding my PC hostname and IP. I’ve turned off firewalls on Windows. I’ve exported ROS_MASTER_URI and ROS_IP. Nothing works. Any ideas ?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-05-13 10:46:00 -0500

Lol gravatar image

I just solved it, if someone has the same problem, using "ROS for LabVIEW Software" from GitHub, entering "/user.lib/ROS for LabVIEW Software/ROS/Code/ROS_Tools/ROSTerminal.vi", you only have to change the node IP inside it!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-05-13 03:34:58 -0500

Seen: 536 times

Last updated: May 13 '20