Ask Your Question

can not launch node of type [robot_pose_ekf/robot_pose_ekf]: cannot locate node of type [robot_pose_ekf] in package [robot_pose_ekf]

asked 2020-05-07 00:42:46 -0600

jkaplan1123 gravatar image

updated 2020-05-07 07:12:00 -0600

gvdhoorn gravatar image

I am running Melodic in Ubuntu 18.04 in a VM.

I tried uninstalling and the reinstalling the package from the git (as found in the documentation), but ran into the same error. I was able to build the package using rosbuild and build the workspace using catkin_make_isolated

When I run the command: roslaunch robot_pose_ekf robot_pose_ekf.launch I get the following as my output:

parallels@parallels:~/autorobot_ws$ roslaunch robot_pose_ekf robot_pose_ekf.launch 
... logging to /home/parallels/.ros/log/3b031c06-9019-11ea-a883-001c42bcca12/roslaunch-parallels-7626.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://parallels:40787/


 * /robot_pose_ekf/base_footprint_frame: base_footprint
 * /robot_pose_ekf/freq: 30.0
 * /robot_pose_ekf/imu_used: True
 * /robot_pose_ekf/odom_used: True
 * /robot_pose_ekf/output_frame: odom_combined
 * /robot_pose_ekf/sensor_timeout: 1.0
 * /robot_pose_ekf/vo_used: True
 * /rosdistro: melodic
 * /rosversion: 1.14.5

    robot_pose_ekf (robot_pose_ekf/robot_pose_ekf)


ERROR: cannot launch node of type [robot_pose_ekf/robot_pose_ekf]: Cannot locate node of type [robot_pose_ekf] in package [robot_pose_ekf]. Make sure file exists in package path and permission is set to executable (chmod +x)
No processes to monitor
shutting down processing monitor...
... shutting down processing monitor complete

I then ran rosrun robot_pose_ekf as per some advice as suggested in the troubleshooting guide. I got the following as my output:

Traceback (most recent call last):
  File "/home/parallels/autorobot_ws/src/robot_pose_ekf/scripts/", line 4, in <module>
    from robot_pose_ekf.srv import GetStatus, GetStatusRequest
ImportError: No module named robot_pose_ekf.srv
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2020-05-10 20:02:47 -0600

jkaplan1123 gravatar image

For some reason, downloading the catkin tools toolbox, running catkin init on my workspace followed by catkin clean and catkin build worked. I have no idea why, but it did. Hope this helps anyone else with the same issue in the future.

edit flag offensive delete link more

answered 2020-05-07 10:01:58 -0600

nihalsoans91 gravatar image

Did you check the usual suspects like sourcing the setup.bash file ?

edit flag offensive delete link more


Yes I have. I run source ~/autorobot_ws/devel/setup.bash

jkaplan1123 gravatar image jkaplan1123  ( 2020-05-07 11:53:38 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2020-05-07 00:42:46 -0600

Seen: 340 times

Last updated: May 10 '20