ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
1

Customising Packages on ROS Tutorial Issue

asked 2020-05-05 08:35:21 -0600

jimc91 gravatar image

I am very new to ROS & Ubuntu and am working through the OS tutorials.

Specifically, I am currently creating and customising my own packages (see link below for tutorial I am currently referencing, I am currently on section 6 (customising my package).

http://wiki.ros.org/ROS/Tutorials/Cre...

I am using ROS Kinetic & Ubuntu16.04 LTS.

In section 6.1.1 I am trying to add a description tag, but I am confused how to.

The instructions are as follows:

6.1.1 description tag

First update the description tag:

<description>The beginner_tutorials package</description>

Note: Change the description to anything you like, but by convention the first sentence should be short while covering the scope of the package. If it is hard to describe the package in a single sentence then it might need to be broken up.

I have tried to enter a one word description of the package but get an error.

So my description is as follows:

jamescoady@jamescoady-Inspiron-5579:~$ <rostutorial>The beginner_tutorials package</rostutorial>

I then get the error:

bash: syntax error near unexpected token `newline'

When I remove < & > from my line I still get an error.

jamescoady@jamescoady-Inspiron-5579:~$ rostutorialThe beginner_tutorials package /rostutorial

I then get the error:

rostutorial: command not found

What am I doing wrong? I know this is probably a very basic error on my behalf and I do apologise if it is an awfully stupid question!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2020-05-05 09:00:49 -0600

gvdhoorn gravatar image

The manifest (that's what package.xml is called) is a plain XML file, which is essentially just text.

So to "update the description tag", you open the file in a text editor (of your choice), edit the text you want to change, save the file and close the editor.

There are no commands to run here.

edit flag offensive delete link more

Comments

Some else had recommended using gedit package.xml to do the editing. I ran that script and a texteditor opened, but no text appeared. Any thoughts?

sassenach6868 gravatar image sassenach6868  ( 2021-02-13 10:25:56 -0600 )edit

Have you made sure to run it in the directory which contains the package.xml? If you don't, gedit will assume you're trying to create a new file -- with the name package.xml -- and will show an empty editor.

gvdhoorn gravatar image gvdhoorn  ( 2021-02-13 11:15:30 -0600 )edit
1

answered 2020-05-05 09:00:39 -0600

mgruhler gravatar image

updated 2020-05-05 09:01:11 -0600

This is not a command.

You are expected to edit the respective file (package.xml) with a text editor.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-05-05 08:35:21 -0600

Seen: 94 times

Last updated: May 05 '20