Ask Your Question
0

[ERROR] [1588286007.343230]: Current /drone/down_camera/image_raw not ready yet, retrying for getting down_camera_rgb_image_raw

asked 2020-04-30 17:52:25 -0500

ltbd78 gravatar image

updated 2020-04-30 17:54:07 -0500

I am using a script (appended to the end of this post) to setup my workspace on my Ubuntu18.04. After setting everything up I ran the following lines:

Terminal 1: roslaunch my_parrotdrone_openai_example start_training_v2.launch

Terminal 2: rosrun sjtu_drone start_gui

However I'm receiving the error:

[ERROR] [1588286007.343230]: Current /drone/down_camera/image_raw not ready yet, retrying for getting down_camera_rgb_image_raw

When doing a rostopic list, I only have the following /drone related topics available:

/drone/down_camera/image_raw
/drone/gt_acc
/drone/gt_pose
/drone/gt_vel
/drone/imu
/drone/land
/drone/posctrl
/drone/reset
/drone/sonar
/drone/takeoff
/drone/vel_mode

When looking at the source code, it appears there are a lot of missing camera topics.

When I run different non-openai launch file, i.e., roslaunch sjtu_drone contest.launch, all topics are available.

How do I fix the missing-topic issue?

Setup Script:

#!/bin/bash

DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" >/dev/null 2>&1 && pwd )"

# Get Base Packages
mkdir -p ~/simulation_ws/src
cd ~/simulation_ws/src
git clone -b version2 https://bitbucket.org/theconstructcore/openai_ros.git
git clone -b version2 https://bitbucket.org/theconstructcore/openai_examples_projects.git
git clone -b kinetic-gazebo9 https://bitbucket.org/theconstructcore/parrot_ardrone.git
sed -i "s/user/$USER/g" ~/simulation_ws/src/openai_examples_projects/my_parrotdrone_openai_example/config/*v2.yaml

# Install Dependencies
# sudo rosdep init # run this line if first time running
rosdep update
rosdep install --from-paths . -i

# Build
cd ~/simulation_ws
catkin_make
source devel/setup.bash
rospack profile

cd $DIR
edit retag flag offensive close merge delete

Comments

1

I would really suggest you post an issue on the theconstructcore repositories, as it would appear almost all packages you use come from there.

The chances their devs/maintainers/instructors see you post here are rather slim.

If you do end up posting on their issue trackers, please post a comment here with a link to your issue, so we can keep things connected.

gvdhoorn gravatar image gvdhoorn  ( 2020-05-01 03:27:50 -0500 )edit
1

Just posted. Here's the link

ltbd78 gravatar image ltbd78  ( 2020-05-01 11:31:06 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-05-01 15:56:02 -0500

ltbd78 gravatar image

updated 2020-05-15 12:05:48 -0500

Solved: Issue was due to running roslaunch my_parrotdrone_openai_example start_training_v2.launch in a ssh terminal rather than from the VM itself. The full list of ROS topics becomes available when using terminal within VM.

New Issue: When running rosrun sjtu_drone start_gui or gzserver the VM display goes black. I believe it is an issue with the my_parrotdrone_openai_example package as this does not occur with roslaunch drone_construct main.launch and rosrun sjtu_drone start_gui.

New Issue Fixed! Steps:

  1. In parrotdrone_goto.py (task env), change the ROSLauncher line so it’s: ROSLauncher(rospackage_name="sjtu_drone", launch_file_name="contest.launch", ros_ws_abspath=ros_ws_abspath)

  2. In parrotdrone_env.py (robot env), comment out the ROSLauncher() line.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-04-30 17:52:25 -0500

Seen: 28 times

Last updated: May 15