Problem with multiple workspaces

asked 2020-04-29 23:05:19 -0600

zhuz gravatar image

I have two workspaces /catkin_ws and /carto_ws. I created them individually without any copy and paste. The first workspace /catkin_ws is made with "catkin_make" while the other is "catkin_make_isolated --install --use-ninja".

When I launched a launch file in the /catkin_ws (I ran "source devel/setup.bash" before I did), one of the nodes has an error of ERROR: cannot launch node of type [tf_handler/tf_handler_node]: can't locate node [tf_handler_node] in package [tf_handler]

This package has an exact same one in another workspace but I didn't create them through copying. So I ran "rosrun tf_handle tf_handler_node" and it suggested: [rosrun] Couldn't find executable named tf_handler_node below /home/walker/carto_ws/install_isolated/share/tf_handler

Seems like it's looking for executable in the wrong workspace. But I ran the source command several times and it didn't help. How do I fix this problem ???

edit retag flag offensive close merge delete