Rqt_gui could not include cpp plugin

asked 2020-04-14 21:21:05 -0500

Labid52 gravatar image

updated 2020-12-15 14:17:58 -0500

jayess gravatar image

Hi, I am using ros-kinetic in ubuntu 16.04. while I run the following command It shows the following error,

command :

rosrun rqt_gui rqt_gui

error:

Could not import "pyqt" bindings of qt_gui_cpp library - so C++ plugins will not be available:
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui_cpp/cpp_binding_helper.py", line 43, in <module>
    from . import libqt_gui_cpp_sip
ImportError: dynamic module does not define module export function (PyInit_libqt_gui_cpp_sip)

I have reinstalled rqt, but still problem persist. I have checked the availability of py_qt and also reinstalled ubuntu-core-launcher. But it remains the same.

edit retag flag offensive close merge delete

Comments

Hi,

I have the same issue as you have so unfortunately I don't know the answer yet. Did you meanwhile solve this error? If yes, could you please help me out? If no, I will continue to search for an answer and maybe I will be able to help you out! I couldn't find a lot of other topics related to this error.

Best,

alme96

alme96 gravatar image alme96  ( 2020-12-15 09:42:38 -0500 )edit