ROS Melodic install causes Ubuntu Software Updater to give "Not all updates can be installed"

asked 2020-04-10 15:58:07 -0500

ender1618 gravatar image

I am on Ubuntu 18.04, installed ROS Melodic following the instructions here:

After, running sudo apt update yields:

... 52 packages can be upgraded. Run 'apt list --upgradable' to see them.

apt list --upgradable yields a list of 52 libs:

These are all libs installed by ROS

if i try to do a sudo apt update && apt upgrade i get:

Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages have been kept back: libgdal-dev libgdal20 libopencv-calib3d-dev libopencv-calib3d3.2 libopencv-contrib-dev
libopencv-contrib3.2 libopencv-core-dev libopencv-core3.2 libopencv-dev libopencv-features2d-dev libopencv-features2d3.2 libopencv-flann-dev libopencv-flann3.2 libopencv-highgui-dev
libopencv-highgui3.2 libopencv-imgcodecs-dev libopencv-imgcodecs3.2 libopencv-imgproc-dev
libopencv-imgproc3.2 libopencv-ml-dev libopencv-ml3.2 libopencv-objdetect-dev libopencv-objdetect3.2
libopencv-photo-dev libopencv-photo3.2 libopencv-shape-dev libopencv-shape3.2 libopencv-stitching-dev
libopencv-stitching3.2 libopencv-superres-dev libopencv-superres3.2 libopencv-ts-dev libopencv-video-dev libopencv-video3.2 libopencv-videoio-dev libopencv-videoio3.2
libopencv-videostab-dev libopencv-videostab3.2 libopencv-viz-dev libopencv-viz3.2 libopencv3.2-java libopencv3.2-jni libvtk6-dev libvtk6-java libvtk6-jni libvtk6-qt-dev libvtk6.3 libvtk6.3-qt python-opencv python-vtk6 tcl-vtk6 vtk6 0 upgraded, 0 newly installed, 0 to remove and 52 not upgraded.

When i run Software Updater i get a dialog that says:

Not all updates can be installed Run a partial upgrade, to install as many updates as possible. ... options for "partial upgrade" or "continue"

If i choose partial upgrade, it will be able to upgrade the 52 libs, but will need to remove ros-melodic-desktop-full

Doing a sudo apt dist-upgrade yields the same result.

Its looks like the latest ros-melodic ubuntu bionic install from uses versions of libs that ubuntu disapproves of?

How can i fix this?

Any assistance would be appreciated.

Thanks, -Ryan

edit retag flag offensive close merge delete


It's possible you have PPAs or other deb repositories enabled which provide conflicting versions of packages. Conflicting in this case means: if the ROS pkgs depend on very specific versions, then having others installed will cause the required versions to be installed instead. If you then try to upgrade those dependencies, the ROS pkgs will be uninstalled.

I'm not claiming that's the cause here, but it is one possibility.

You could see whether aptitude can provide some more insight into why it wants to (un)install certain things. Another alternative would be synaptic, and seeing where the upgrades come from.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-11 03:37:07 -0500 )edit

I have tried the above and i still get that warning from Software Updater, I am not sure how to use aptitude to resolve this.

ender1618 gravatar image ender1618  ( 2020-04-21 23:50:12 -0500 )edit