Ask Your Question
0

Autoware ROSBAG Demo no points_map [closed]

asked 2020-04-07 02:57:06 -0600

GeorgNo gravatar image

updated 2020-04-20 08:35:32 -0600

Hello,

my problem is that I do not get the expected output if I follow the instructions for the rosbag demo (link), namely no /points_map is published by my_map.launch and also no tf between velodyne and base_link is present, thus also failing the detection.

Here the setup I am using:

  • Ubuntu 18.04 + ROS Meldoic [Host], AMD Ryzen 7 3800X, Nvidia RTX 2070 super
  • Docker (Version: 19.03.08) : autoware/autoware:latest-melodic-cuda

I uploaded a video of my steps: link.
Here are the commands I entered:

Host:

 mkdir -p ~/shared_dir   
 wget https://autoware-ai.s3.us-east-2.amazonaws.com/sample_moriyama_data.tar.gz  
 wget https://autoware-ai.s3.us-east-2.amazonaws.com/sample_moriyama_150324.tar.gz  
 tar zxfv sample_moriyama_150324.tar.gz     # also tried extracting in docker container
 tar zxfv sample_moriyama_data.tar.gz       # also tried extracting in docker container
 cd <path-to-autoware-docker-git>/generic && ./run.sh

Docker:

 mkdir -p ~/.autoware && cd ~/.autoware
 ln -s ~/shared_dir/data                             # also tried it with cp, made no difference
 ln -s ~/shared_dir/sample_moriyama_150324.bag       # also tried it with cp, made no difference
 roslaunch runttime_manager runtime_manager.launch

After running roslaunch I followed instructions of here / the video found here

Thank you for your help.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by GeorgNo
close date 2020-08-23 03:18:14.943986

2 Answers

Sort by ยป oldest newest most voted
2

answered 2020-08-17 16:45:37 -0600

bfroemel gravatar image
edit flag offensive delete link more

Comments

Hey, I just pulled the docker image from hub and still have the same problem. Also changed the my_map.launch to match your commit. Did you build autoware from source? Thank you for your help

GeorgNo gravatar image GeorgNo  ( 2020-08-21 16:12:11 -0600 )edit

Strange - replacing the my_map.launch file should be all it needs to get the rosbag demo working on the currently latest docker image (1.14.0). Could you verify your Autosar version:

git --git-dir=/home/autoware/Autoware/src/autoware/common/.git describe --tags

and that all files related to the demo are at the proper location (e.g., bin_Laser- pcd files in ~/.autoware/data/map/pointcloud_map)? In the gnome-terminal window which pops up after launching the Autoware runtime manager you should see log messages regarding loading pcd files:

['roslaunch', '/home/autoware/Autoware/src/autoware/documentation/autoware_quickstart_examples/launch/rosbag_demo/my_map.launch']
pid=6999
sched policy=OTHER prio=0
load /home/autoware//.autoware/data/map/pointcloud_map/bin_Laser-00167_-00864.pcd
load /home/autoware//.autoware/data/map/pointcloud_map/bin_Laser-00153_-00852.pcd
load /home/autoware//.autoware/data/map/pointcloud_map/bin_Laser-00159_-00859.pcd
bfroemel gravatar image bfroemel  ( 2020-08-22 05:54:53 -0600 )edit

The default launchfile of 1.14.0 didn't work for me (checked the version with your command). Needed to change it to your pr rebuild with AUTOWARE_COMPILE_WITH_CUDA=1 colcon build --symlink-install --packages-select autoware_quickstart_examples --cmake-args -DCMAKE_BUILD_TYPE=Release and then fire everything up. Now on the first start rviz won't show me the pcl, I always need to restart it. Thanks for the help

GeorgNo gravatar image GeorgNo  ( 2020-08-23 03:07:00 -0600 )edit
0

answered 2020-04-11 17:33:01 -0600

omkard gravatar image

updated 2020-04-11 17:33:25 -0600

Hi @GeorgNo

If you follow the provided video in the tutorial correctly at 1:40, please turn off and on the points map, you will be able to see the expected output.

Thanks!

edit flag offensive delete link more

Comments

Hi @omkard,

thank you for your help!

I followed the video step by step (see following video) and also turned the points map off and on in rviz but still can not see it.

Some additional information that might be useful for you to help me:

  • to get gpu acceleration running I needed to change RUNTIME="--runtime=nvidia" to RUNTIME="--gpus all" on my host in the generic/run.sh file. Otherwise docker would throw following error: docker: Error response from daemon: Unknown runtime specified nvidia.
    • inside the container I edited the path to the install/setup.bash, since the provided path always threw no such file or directory, in runtime_manager/scripts/run

Thank you again for your help!

GeorgNo gravatar image GeorgNo  ( 2020-04-14 07:58:25 -0600 )edit

Hi @GeorgNo

Try multiple times by playing and pausing the simulation and turning on and off the points map. That's the only thing I could try.

And, I believe changing the runtime to what you provided is good but I am not sure about the path to install/setup.bash. Thank you!

omkard gravatar image omkard  ( 2020-04-14 10:40:14 -0600 )edit

@omkard sadly switching it off and on does not work. Do you have any other idea what I might try?

GeorgNo gravatar image GeorgNo  ( 2020-04-16 05:18:56 -0600 )edit

No @GeorgNo, I don't have any.

omkard gravatar image omkard  ( 2020-04-16 07:52:55 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2020-04-07 02:57:06 -0600

Seen: 503 times

Last updated: Apr 20 '20