Freenect drivers no longer detecting Kinect

asked 2020-04-06 11:57:28 -0600

Joey Tan gravatar image

I'm running ROS Kinetic on a raspberry pi, Raspbian Buster.

I ran sudo apt-get update && sudo apt-get upgrade earlier to update everything but now I get No devices connected.... Waiting for devices to be connected whenever I try and use the Kinect (e.g. roslaunch freenect_launch freenect.launch, though it's not exclusive to this). This happens regardless of if the Kinect is actually plugged into the pi. Everything was working perfectly fine before this but apparently updating things broke something.

Using lsusb lists the Kinect as connected, so it is being detected and recognized by the pi.

I've tried rebuilding the workspace (rosinstall_generator freenect_launch ... and wstool merge, update, etc... and then building) and reinstalling libfreenect from source, but to no avail.

What broke?

edit retag flag offensive close merge delete

Comments

Could perhaps be an updated kernel was installed as part of running sudo apt-get upgrade? Would be something to check.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-07 03:09:09 -0600 )edit

@gvdhoorn How can I check if that's the case? I do remember that it took some time to complete, but I'm not sure if that's what happened (out of ignorance, not doubt). And if it happens to be the case, what could be done to fix the problem?

Joey Tan gravatar image Joey Tan  ( 2020-04-07 07:39:49 -0600 )edit

You could check /var/log/dpkg.log to see whether it says anything about packages with linux-image in them getting installed.

You'll want to read that file 'backwards' though, as entries are appended to it. See also the date+time stamps at the beginning of each line.

And if it happens to be the case, what could be done to fix the problem?

Older kernels are typically left on the system, just in case you'd want to start an older version for whatever reason. You could try booting into the previous version and see whether that changes anything.

But this is really all just a guess, something I would check if this would've happened to me.

There is a good chance the cause is actually something completely different.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-07 07:51:56 -0600 )edit

No such luck :/

Joey Tan gravatar image Joey Tan  ( 2020-04-08 22:28:30 -0600 )edit