Ask Your Question
0

Unable to interface moveit with gazebo - Controllers not loaded and unable to spawn robot model

asked 2020-04-03 14:36:30 -0600

R_CODEC gravatar image

I'm trying to interface moveit with gazebo for simulation.
I'm following the construct sim tutorial for the same, which uses ubuntu 16.04 and ros-kinetic
https://www.theconstructsim.com/contr...

I'm using ros-melodic and ubuntu 18.04 with gazebo - version 9.12
Linux 5.3.0-42-generic x86_64 HP pavillion notebook

UR package that i downloaded for urdf from melodic-devel branch https://github.com/ros-industrial/uni...

Question 1 : I'm unable to see the action servers having type of controller FollowJointTrajectory as it is given in the tutorial when i run [ $ rostopic list ] after launching ur5.launch in the ur package

Terminal shows this

$ rostopic list
/calibrated
/clock
/gazebo/link_states
/gazebo/model_states
/gazebo/parameter_descriptions
/gazebo/parameter_updates
/gazebo/set_link_state
/gazebo/set_model_state
/joint_group_position_controller/command
/joint_states
/rosout
/rosout_agg
/tf

and i suppose this could be one of the reasons of not getting the controllers loaded to gazebo.

The model also gets loaded to gazebo which is very translucent as in i think it is not spawned correctly and i recieve this error

    $ roslaunch ur_gazebo ur5.launch 

    Checking log directory for disk usage. This may take a while.
    Press Ctrl-C to interrupt
    Done checking log file disk usage. Usage is <1GB.

    xacro: in-order processing became default in ROS Melodic. You can drop the option.
    started roslaunch server http://xxxx-HP-Pavilion-Laptop-xxxxxxx/

    SUMMARY
    ========

    PARAMETERS
     * /arm_controller/action_monitor_rate: 10
     * /arm_controller/constraints/elbow_joint/goal: 0.1
     * /arm_controller/constraints/elbow_joint/trajectory: 0.1
     * /arm_controller/constraints/goal_time: 0.6
     * /arm_controller/constraints/shoulder_lift_joint/goal: 0.1
     * /arm_controller/constraints/shoulder_lift_joint/trajectory: 0.1
     * /arm_controller/constraints/shoulder_pan_joint/goal: 0.1
     * /arm_controller/constraints/shoulder_pan_joint/trajectory: 0.1
     * /arm_controller/constraints/stopped_velocity_tolerance: 0.05
     * /arm_controller/constraints/wrist_1_joint/goal: 0.1
     * /arm_controller/constraints/wrist_1_joint/trajectory: 0.1
     * /arm_controller/constraints/wrist_2_joint/goal: 0.1
     * /arm_controller/constraints/wrist_2_joint/trajectory: 0.1
     * /arm_controller/constraints/wrist_3_joint/goal: 0.1
     * /arm_controller/constraints/wrist_3_joint/trajectory: 0.1
     * /arm_controller/joints: ['shoulder_pan_jo...
     * /arm_controller/state_publish_rate: 25
     * /arm_controller/stop_trajectory_duration: 0.5
     * /arm_controller/type: position_controll...
     * /gazebo/enable_ros_network: True
     * /joint_group_position_controller/joints: ['shoulder_pan_jo...
     * /joint_group_position_controller/type: position_controll...
     * /joint_state_controller/publish_rate: 50
     * /joint_state_controller/type: joint_state_contr...
     * /robot_description: <?xml version="1....
     * /robot_state_publisher/publish_frequency: 50.0
     * /robot_state_publisher/tf_prefix: 
     * /rosdistro: melodic
     * /rosversion: 1.14.5
     * /use_sim_time: True

    NODES
      /
        arm_controller_spawner (controller_manager/controller_manager)
        fake_joint_calibration (rostopic/rostopic)
        gazebo (gazebo_ros/gzserver)
        gazebo_gui (gazebo_ros/gzclient)
        joint_state_controller_spawner (controller_manager/controller_manager)
        robot_state_publisher (robot_state_publisher/robot_state_publisher)
        ros_control_controller_manager (controller_manager/controller_manager)
        spawn_gazebo_model (gazebo_ros/spawn_model)

    auto-starting new master
    process[master]: started with pid [24412]
    ROS_MASTER_URI=http://localhost:11311

    setting /run_id to 8a547ef4-75d3-11ea-bcec-302432c29868
    process[rosout-1]: started with pid [24423]
    started core service [/rosout]
    process[gazebo-2]: started with pid [24430]
    process[gazebo_gui-3]: started with pid [24435]
    process[spawn_gazebo_model-4]: started with pid [24440]
    process[robot_state_publisher-5]: started with pid [24441]
    process[fake_joint_calibration-6]: started with pid [24442]
    process[joint_state_controller_spawner-7]: started with pid [24448]
    process[arm_controller_spawner-8]: started with pid [24450]
    process[ros_control_controller_manager-9]: started with pid [24451]
    [ INFO] [1585936203.649255599]: Finished loading Gazebo ROS API Plugin.
    [ INFO] [1585936203.651239013]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
    [ INFO] [1585936203.713316303]: Finished loading Gazebo ROS API Plugin.
    [ INFO] [1585936203.715368125]: waitForService: Service [/gazebo_gui/set_physics_properties] has not been advertised, waiting...
    [INFO] [1585936203.982848, 0.000000]: Loading model ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-12 14:41:13 -0600

R_CODEC gravatar image

I solved the error after upgrading the ros-control-package Now it's working.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-04-03 14:36:30 -0600

Seen: 55 times

Last updated: Apr 12 '20