Ask Your Question
0

Open planner stack and dp planner

asked 2020-04-03 03:56:03 -0500

Mackou gravatar image

updated 2020-04-03 03:57:18 -0500

Hello everyone.

I am currently trying to get OP planner avoid and stop before obstacles, so far without success.

So far the nodes I use are :

Global planning :

  • op_global_planner

Local planning :

  • op_common_params
  • op_behavior_selector
  • op_motion_predictor
  • op_trajectory_evaluator
  • op_trajectory_generator

Obstacle detection : - ray_ground_filter - lidar_euclidean_cluster_detect - imm_ukf_pda_track

It works perfectly to generate a path and follow it. Roll out trajectories are also generated. The problem is that nothing subscribes to any obstacle detection topic.

Do you know if this is supposed to work like this ? And how to get OP use detected objects ?

I also stumbled across this GitHub issue about dp_planner and it seems that it includes object detection. I also checked the Autoware Package and it seems that it contains parameters related to object detection. But of course no documentation.

Should I drop all the op_xxx packages and use dp_planner instead ? Do they work together ?

There is no information anywhere.

@Hatem , You helped me before, would you be so kind to have a look at this too ? ๐Ÿ™

Of course anyone is welcome to give me a hint here.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-04-03 04:19:36 -0500

Hatem gravatar image

Hello,

No problem, I can help.

I just fixed this issue for Autoware1.13 yesterday :)

The issue is that imm_ukf_pda_track output the Objects data in "velodyne" frame. But OpenPlanner expects it to be in "map" frame. also the topic names are different.

so how to solve this problem:

Solution 1:

  • In lidar_euclidean_cluster_detect, set the output frame to be "map"
  • Use lidar_kf_contour_tracker.

Solution 2:

  • Add a bridge node that transform the output from imm_ukf_pda_track to "map" frame and publish it with the same topic as in op_motion_predictor.

Hope This is helpful.

Regards,

edit flag offensive delete link more

Comments

if you want to fresh fixed version use the one from branch openplanner.1.13, but it is not tested yet

Hatem gravatar image Hatem  ( 2020-04-03 04:20:50 -0500 )edit

@Hatem Thanks a lot for your answer.

I have tried to set the output frame of lidar_euclidean_cluster_detect to "map" . But now the detected boxes are shifted in rviz, is that normal ?

Also /lidar_kf_contour_tracker subscribes to /cloud_clusters but lidar_euclidean_cluster_detect publishes in /points_cluster

Do I need to republish it ?

Mackou gravatar image Mackou  ( 2020-04-03 04:42:49 -0500 )edit

the topics do not match

[ERROR] [1585907078.578334622]: Client [/lidar_kf_contour_track] wants topic /cloud_clusters to have datatype/md5sum [autoware_msgs/CloudClusterArray/5bdd7c958335da845b88351aab5141d4], but our version has [sensor_msgs/PointCloud2/1158d486dd51d683ce2f1be655c3c181]. Dropping connection.
Mackou gravatar image Mackou  ( 2020-04-03 04:46:24 -0500 )edit

It is visualization issue, The visualization only expect velodyne frame.

And you don't need the cloud cluster topic , you can disable that in lidar kf contour tracker

Only use detected objects topic.

Openplanner publish visualization information in map frame. You can use it.

Regards

Hatem gravatar image Hatem  ( 2020-04-03 04:55:10 -0500 )edit

@Hatem thanks again.

How do I disable the cloud cluster topic in kf contour tracker ?

How do I use detected objects ? What should subscribe to it ? And in what topic ?

[EDIT] I managed to make OP use the tracked objects but it doesnt avoid them at all. Any idea ?

Mackou gravatar image Mackou  ( 2020-04-03 05:39:48 -0500 )edit

@Hatem

Here is what my current status look like : https://imgur.com/a/x8qy8Yk I have the object detected in open planner, and I have the red detected_polygon.

But OP doesnt take it into account when generating the trajectories and the car just bump into the obstacle. Any idea ?

Mackou gravatar image Mackou  ( 2020-04-03 08:55:14 -0500 )edit
  • Make sure Enable Following & Enable Avoidance is checked

  • In pure pursuit make sure you select Waypoint not Dialog.

Hatem gravatar image Hatem  ( 2020-04-03 09:26:42 -0500 )edit

@Hatem Thanks again.

enableFollowing is true. I dont have any enableAvoidance, but enableSwerving is true.

In pure pursuit I dont have any parameter related to waypoint or Dialog. Where do I set this ?

Also I am not sure the object is really taken into account as I dont see any stopline in rviz

Im really stuck here

Mackou gravatar image Mackou  ( 2020-04-03 10:26:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-04-03 03:56:03 -0500

Seen: 474 times

Last updated: Apr 03 '20