Ask Your Question
0

Basic doubt:: Husky Robot Movement Query

asked 2020-04-01 12:05:03 -0600

Viki93 gravatar image

updated 2020-04-12 16:46:02 -0600

Hello All, I'm a new user to ROS. I would like to detail my query to help understand my problem.

  1. Open a terminal window, and enter: "roslaunch husky_gazebo husky_empty_world.launch " --> Working fine --> Gazebo opens
  2. Open another terminal window, and enter: "roslaunch husky_viz view_robot.launch" --> Working fine --> Rviz opens.

  3. I'm not sure how to execute this command: rostopic pub /husky_velocity_controller/cmd_vel geometry_msgs/Twist: --> I give Tab command and then I get the following output: x: 0.0 y: 0.0 z: 0.0 angular: x: 0.0 y: 0.0 z: 0.0" -r 10

upon execution I do not see my robot moving. I need some clear step by step info on how to execute this, as I'm going mad as I cant get any info/ results. Please support me in how to go next. Thank you in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-01 18:56:57 -0600

All the values are 0 so the Husky won't move. Try setting linear x to 0.1.

edit flag offensive delete link more

Comments

Thank you for the reply. My problem is I do not know how to enter the value of x = 0.1 in the commandline. Because i'm getting confused on the usage of the last line (point 3) of code. I need some info on that. Can you please help?

Viki93 gravatar image Viki93  ( 2020-04-02 03:48:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-04-01 12:05:03 -0600

Seen: 91 times

Last updated: Apr 12 '20