Ask Your Question
3

getting ERROR: Rosdep cannot find all required resources to answer your query after using "rosedep install <package>"

asked 2020-03-28 09:20:18 -0600

m.kleiner gravatar image

updated 2020-03-30 15:26:18 -0600

Hello, I'm new to ROS and I'm trying to find my way around. After reading the ROS tutorials I sat to my own project, for that project I downloaded packages from GitHub. After doing git clone https://github.com/<package_path>.git I tried to do rosdep install <package> but all I got was that ERROR msg:

ERROR: Rosdep cannot find all required resources to answer your query
Missing resource <package> 
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/user/ros/ros-pkg
ROS path [2]=/another/path

I tried to search online for a solution to that problem but couldn't find one.

Thank you for your help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2020-03-28 11:46:58 -0600

gvdhoorn gravatar image

updated 2020-03-28 11:47:30 -0600

You're likely to want to use the following command instead:

rosdep update
rosdep install --from-paths /path/to/catkin_ws/src --ignore-src -y --rosdistro=kinetic

The first updates your rosdep database, the second command looks in the src space for ROS packages, gathers all their dependencies, removes the ones satisfied by packages in your source space and then asks apt to install everything not present.

Additionally:

ROS path [1]=/home/user/ros/ros-pkg

from this it's not entirely clear to me whether you've actually created a Catkin workspace.

You'll want to create one. See Creating a workspace for catkin for some guidance.

edit flag offensive delete link more

Comments

Hey, I tried to run these commands, But unfortunately I got the same error.

compm@compm-VirtualBox:~/catkin_ws$ rosdep install baxter_demos

ERROR: Rosdep cannot find all required resources to answer your query
Missing resource baxter_demos
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/compm/catkin_ws/src
ROS path [2]=/opt/ros/kinetic/share

I created catkin workspace (following the guide you sent), Therefore I surmise it is not the source of the problem. In the github page of the package i try to install It mentions that I should have the repository cloned into ROS_PACKAGE_PATH which im not sure what it means. Maybe this is the root of the problem.

##Prerequisites

Install dependencies (assumes that you have the repo cloned into your ROS_PACKAGE_PATH):

rosdep install baxter_demos

Thank you in advanced for your help

m.kleiner gravatar image m.kleiner  ( 2020-03-30 15:23:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-03-28 09:20:18 -0600

Seen: 1,710 times

Last updated: Mar 30 '20