ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Unable to locate package libboost-python-1.58.0

asked 2020-03-17 10:26:39 -0500

yimiya gravatar image

updated 2020-03-17 11:11:36 -0500

gvdhoorn gravatar image

I want to install the autoware in my ubuntu16.04, I have already installed ROS kinetic and QT5.12, then I followed the instructions below: https://gitlab.com/autowarefoundation...

When I got to the step:

rosdep install -y --from-paths src --ignore-src --rosdistro $ROS_DISTRO

I got a problem shows below:

E: Unable to locate package libboost-python-1.58.0
E: couldn't find any package by glob 'libboost-python-1.58.0'
E: couldn't find any package by regex 'libboost-python-1.58.0'
ERROR: the following rosdeps failed to install apt: command [sudo -H apt-get install -y libboost-python-1.58.0] failed

I tried many methods, including change sources.list, but nothing worked.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2020-03-18 12:19:36 -0500

marguedas gravatar image

Apologies, there is a typo in the rosdep rule for Ubuntu Xenial, this PR should fix it https://github.com/ros/rosdistro/pull....

Once it is merged you should be able to just run rosdep update and try again.

In the meantime, you can install the package by hand and tell rosdep to ignore that key:

sudo apt update && sudo apt install -y libboost-python1.58.0
rosdep install -y --from-paths src --ignore-src --rosdistro $ROS_DISTRO --skip-keys libboost-python
edit flag offensive delete link more
0

answered 2020-03-17 12:22:04 -0500

Josh Whitley gravatar image

One possible reason for this error is that the current release of Autoware.AI only supports Ubuntu 18.04 (as shown in the chart on the page to which you linked).

edit flag offensive delete link more

Comments

Thank you so much ! I'll check it out.

yimiya gravatar image yimiya  ( 2020-03-18 05:17:21 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2020-03-17 10:26:39 -0500

Seen: 766 times

Last updated: Mar 18 '20