Ask Your Question
0

build.sh return Invalid parameter: bc:hi:r:t:v: without any input

asked 2020-03-09 23:23:27 -0500

Kobecow gravatar image

I'm using Mac OS X 10.15.3 on MBP.
bash: GNU bash, version 3.2.57(1)-release
sorce code hash: da5c5adf7ed11108a571465e737a124139a5f782

I tried to use Autoware Docker environments. I just followed instruction of wiki(https://gitlab.com/autowarefound... I wanted to create a Custom Autoware Docker Container. So my case should be Case 3.

I just run ./build.sh in generic directory. I got only this response.
Invalid parameter: bc:hi:r:t:v:

I tried several patterns. like

./build.sh -c off
Invalid parameter: bc:hi:r:t:v:

./build.sh --help
Invalid parameter: bc:hi:r:t:v:

Why did I always get this response(Invalid parameter: bc:hi:r:t:v:)?

edit retag flag offensive close merge delete

Comments

1

@Kobecow

What does this give?

./build.sh --help
omkard gravatar image omkard  ( 2020-03-12 17:58:40 -0500 )edit

same result. Got Invalid parameter: bc:hi:r:t:v:

Kobecow gravatar image Kobecow  ( 2020-03-12 18:06:05 -0500 )edit

There is something wrong when you get the same error for

./build.sh --help

Check all your steps again or redo again from scracth!

omkard gravatar image omkard  ( 2020-03-12 20:24:27 -0500 )edit

I see. But I did more than 2 times following this link https://gitlab.com/autowarefoundation...

Also I checked all step using set -x option.
text:output ./build.sh --help + CUDA=on + IMAGE_NAME=autoware/autoware + TAG_PREFIX=local + ROS_DISTRO=melodic + BASE_ONLY=false + VERSION= ++ getopt --options bc:hi:r:t:v: --long base-only,cuda:,help,image-name:,ros-distro:,tag-prefix:,version: --name ./build.sh -- --help + OPTS=' -- bc:hi:r:t:v: --long base-only,cuda:,help,image-name:,ros-distro:,tag-prefix:,version: --name ./build.sh -- --help' + eval set -- ' -- bc:hi:r:t:v: --long base-only,cuda:,help,image-name:,ros-distro:,tag-prefix:,version: --name ./build.sh -- --help' ++ set -- -- bc:hi:r:t:v: --long base-only,cuda:,help,image-name:,ros-distro:,tag-prefix:,version: --name ./build.sh -- --help + true + case $1 in + '[' '!' -z bc:hi:r:t:v: ']' + echo 'Invalid parameter: bc:hi:r:t:v:' Invalid parameter: bc:hi:r:t:v: + exit 1

Kobecow gravatar image Kobecow  ( 2020-03-12 20:51:15 -0500 )edit

This is output when I ran ./build.sh --help
build.sh contains set -ex line 2.

Have you tried same thing on MacOS?

Kobecow gravatar image Kobecow  ( 2020-03-12 20:53:03 -0500 )edit

To guarantee that bash is actually the one doing the processing, try running this instead:

$(which bash) -c "build.sh --help"

Just FYI - MacOS is not a supported platform for Autoware.

Josh Whitley gravatar image Josh Whitley  ( 2020-03-12 22:26:29 -0500 )edit

$(which bash) -c "build.sh --help"
/bin/bash: build.sh: command not found

I think it is wrong way to use -c option. I should run $(which bash) -c "bash build.sh --help".

But I got same result.

Kobecow gravatar image Kobecow  ( 2020-03-12 22:58:36 -0500 )edit
1

I think I should you use Ubuntu. I will use EC2(AWS) for using Ubuntu.

Kobecow gravatar image Kobecow  ( 2020-03-12 23:00:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2020-03-12 23:11:02 -0500

Josh Whitley gravatar image

Official answer: MacOS is not a supported platform for Autoware.ai (including for building Docker images). For a list of supported platforms, see https://gitlab.com/autowarefoundation...

edit flag offensive delete link more

Comments

Thank you. I will use Ubuntu

Kobecow gravatar image Kobecow  ( 2020-03-12 23:13:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-03-09 23:23:27 -0500

Seen: 36 times

Last updated: Mar 12