Trying to compile cv_bridge - OpenCVConfig.cmake missing

asked 2020-03-07 15:05:21 -0600

phil123456 gravatar image


can someone point me on where to find this one ?

I tried copying the repositiory of to my catkin/src folder but I still get the error

-- +++ processing catkin package: 'cv_bridge'
-- ==> add_subdirectory(cv_bridge)
-- Found PythonLibs: /usr/lib/arm-linux-gnueabihf/ (found version "2.7.16")
-- Boost version: 1.67.0
-- Found the following Boost libraries:
--   python
CMake Error at cv_bridge/CMakeLists.txt:16 (find_package):
  Could not find a package configuration file provided by "OpenCV" (requested
  version 3) with any of the following names:


  Add the installation prefix of "OpenCV" to CMAKE_PREFIX_PATH or set
  "OpenCV_DIR" to a directory containing one of the above files.  If "OpenCV"
  provides a separate development package or SDK, be sure it has been

can someone help me out ?


edit retag flag offensive close merge delete


This is most likely not what you want to be doing.

See #q346123 for a recent Q&A about what I believe you want/should be doing.

gvdhoorn gravatar image gvdhoorn  ( 2020-03-08 06:27:54 -0600 )edit

it's not even remotely related to missing OpenCVConfig.cmake nor OpenCV ros package

I use a code/compiled ros, not official packages since it's a raspberry pi 4

phil123456 gravatar image phil123456  ( 2020-03-08 11:59:41 -0600 )edit

that referenced question does not seem to be related to this problem, the problem still happens when following that process.

arthurulfeldt gravatar image arthurulfeldt  ( 2020-05-29 20:54:47 -0600 )edit

I could compile it on my side, can't really remember, I just used the regular ros opencv package and switched to ros build utils or something

phil123456 gravatar image phil123456  ( 2020-05-30 05:24:05 -0600 )edit