Ask Your Question
0

rtabmap_ros tutorial zed_stereo_throttle.launch gives unused args error

asked 2020-03-07 12:33:40 -0500

Uwe gravatar image

updated 2020-03-11 07:36:16 -0500

At the moment I'm trying to use remote mapping on a robot with a jetson tx2 and a laptop with ubuntu 16.04. Both run with ros kinetic.

Following this tutorial http://wiki.ros.org/rtabmap_ros/Tutor... I build the throttle launch file on the jetson and recieved the following error.

~/catkin_ws$ roslaunch zed_wrapper zed_stereo_throttle.launch 
... logging to /home/nvidia/.ros/log/03f8b8c0-5fa8-11ea-bbd6-b0fc36b76f7b/roslaunch-tegra-ubuntu-5544.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

unused args [resolution, publish_tf, frame_rate] for include of [/home/nvidia/catkin_ws/src/zed-ros-wrapper/zed_wrapper/launch/zed_camera_nodelet.launch]
The traceback for the exception was written to the log file

I'm kinda lost here because looking at the code for the nodelet I can clearly see the args used. Does someone have any idea as of to what I did wrong?

Thank you in advandce and for reading this.

Edit: Thanks to matlabbes awnser I could start the launch file, but get this enourmus error message:

nvidia@tegra-ubuntu:~$ roslaunch zed_wrapper zed_stereo_throttle.launch
... logging to /home/nvidia/.ros/log/a53abca6-638b-11ea-9403-00187daf6704/roslaunch-tegra-ubuntu-4469.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.0.15:41020/

SUMMARY
========

PARAMETERS
 * /camera/stereo_sync/approx_sync: False
 * /camera/stereo_sync/compressed_rate: 5.0
 * /camera/zed_description: <?xml version="1....
 * /camera/zed_node/auto_exposure: True
 * /camera/zed_node/camera_model: zed
 * /camera/zed_node/confidence: 100
 * /camera/zed_node/depth/confidence_root: confidence
 * /camera/zed_node/depth/depth_stabilization: 1
 * /camera/zed_node/depth/depth_topic_root: depth
 * /camera/zed_node/depth/disparity_topic: disparity/dispari...
 * /camera/zed_node/depth/min_depth: 0.3
 * /camera/zed_node/depth/openni_depth_mode: 0
 * /camera/zed_node/depth/point_cloud_topic_root: point_cloud
 * /camera/zed_node/depth/quality: 1
 * /camera/zed_node/depth/sensing_mode: 0
 * /camera/zed_node/exposure: 100
 * /camera/zed_node/gain: 100
 * /camera/zed_node/general/base_frame: base_link
 * /camera/zed_node/general/camera_flip: False
 * /camera/zed_node/general/camera_frame: zed_camera_center
 * /camera/zed_node/general/frame_rate: 30
 * /camera/zed_node/general/gpu_id: -1
 * /camera/zed_node/general/left_camera_frame: zed_left_camera_f...
 * /camera/zed_node/general/left_camera_optical_frame: zed_left_camera_o...
 * /camera/zed_node/general/resolution: 2
 * /camera/zed_node/general/right_camera_frame: zed_right_camera_...
 * /camera/zed_node/general/right_camera_optical_frame: zed_right_camera_...
 * /camera/zed_node/general/self_calib: True
 * /camera/zed_node/general/serial_number: 0
 * /camera/zed_node/general/svo_compression: 4
 * /camera/zed_node/general/verbose: True
 * /camera/zed_node/general/zed_id: -1
 * /camera/zed_node/mapping/fused_pointcloud_freq: 1.0
 * /camera/zed_node/mapping/mapping_enabled: False
 * /camera/zed_node/mapping/resolution: 1
 * /camera/zed_node/mat_resize_factor: 1.0
 * /camera/zed_node/max_depth: 20.0
 * /camera/zed_node/point_cloud_freq: 10.0
 * /camera/zed_node/stream: 
 * /camera/zed_node/svo_file: 
 * /camera/zed_node/tracking/fixed_cov_value: 1e-6
 * /camera/zed_node/tracking/fixed_covariance: False
 * /camera/zed_node/tracking/fixed_z_value: 1.0
 * /camera/zed_node/tracking/floor_alignment: False
 * /camera/zed_node/tracking/init_odom_with_first_valid_pose: True
 * /camera/zed_node/tracking/initial_base_pose: [0.0, 0.0, 0.0, 0...
 * /camera/zed_node/tracking/map_frame: map
 * /camera/zed_node/tracking/odometry_db: 
 * /camera/zed_node/tracking/odometry_frame: odom
 * /camera/zed_node/tracking/odometry_topic: odom
 * /camera/zed_node/tracking/path_max_count: -1
 * /camera/zed_node/tracking/path_pub_rate: 2.0
 * /camera/zed_node/tracking/pose_topic: pose
 * /camera/zed_node/tracking/publish_map_tf: False
 * /camera/zed_node/tracking/publish_pose_covariance: True
 * /camera ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-03-10 16:12:08 -0500

matlabbe gravatar image

It seems those arguments have been removed from zed_camera_nodelet.launch. Remove those arguments from your zed_camera_nodelet.launch. resolution and frame_rate arguments are optional, but publish_tf would be modified here.

edit flag offensive delete link more

Comments

Thanks that solved the error, though I got some other issues which leaded me to reinstall rtabmap.

Uwe gravatar image Uwe  ( 2020-03-12 05:28:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-03-07 12:33:40 -0500

Seen: 18 times

Last updated: Mar 11