Ask Your Question
0

how to drop the option in ros2

asked 2020-03-01 00:34:33 -0500

Hyo gravatar image

updated 2020-03-01 05:41:57 -0500

gvdhoorn gravatar image

Hi,

It may be a simple question for you. I ran the rosrun function to convert xacro to urdf. Following is the error result from cmd. How can I delete one of the paths?

xacro: in-order processing became default in ROS Melodic. You can drop the option.

resource not found: open_manipulator_description

ROS path [0]=C:\opt\ros\melodic\x64\share\ros

ROS path [1]=C:\opt\ros\melodic\x64\share

when processing file: model.urdf.xacro

Thank you,

Best,

Hyo

edit retag flag offensive close merge delete

Comments

Can you clarify whether you are using ROS 1 or ROS 2?

ROS Melodic is a ROS 1 distribution, however, you mention in ros2 in your question title.

Also: what exactly do you want to "drop"?

gvdhoorn gravatar image gvdhoorn  ( 2020-03-01 05:58:14 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-03-01 11:23:29 -0500

marguedas gravatar image

xacro is complaining about not being able to find the package open_manipulator_description (that is referred to in your xacro file?). Is that package installed on your system ?

If not you can install it using:

sudo apt-get install -y ros-melodic-open-manipulator-description

The message "xacro: in-order processing became default in ROS Melodic. You can drop the option." means that you don't have to pass the --in-order flag to xacro anymore as in order processing is now the default behavior. However not passing the option will not solve your problem, just make the warning go away.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-03-01 00:34:33 -0500

Seen: 61 times

Last updated: Mar 01 '20