Windows 10 Rosserial failed to publish topics to ROS Melodic on Windows 10.

asked 2020-02-18 19:21:47 -0500

Steven94 gravatar image

updated 2022-01-22 16:10:21 -0500

Evgeny gravatar image

I have installed ROS Melodic Morenia latest version (as on Feb 2020) on windows 10 Home. I tried to run ROS Melodic and rosserial windows on the same Windows 10 machine by following this guide []. But the rosserial_hello_world project in visual studio failed to publish the topic into ROS Melodic which installed in the same windows 10 machine with rosserial_server socket_node running. The rosserial_server and rosserial_windows source packages that I used were from [].

I both tried that the socket_node port settings with 11311 and 11411 corresponds in the rosserial_hello_world project's "ros_master" settings. And the IP address that I assigned to "ros_master" in the rosserial_hello_world project is the IP address of the ROS Melodic (which is the same IP address of my windows machine since ROS Melodic is running on the same windows 10 machine).

When running with the port 11411 settings, the rosserial_hello_world VS application seems to somehow successfully establish communication with ROS Melodic (rosserial_server socket_node) running on the same windows 10 machine but still failed to publish the ROS topics into ROS Melodic. The following error was shown.

Socket asio error, closing socket: system:1236

Is there any suggestion to resolve this issue? Similar procedure was tried with rosserial_hello_world VS application (on windows 10 machine) publishing topic to ROS kinetic(on another ubuntu Mate 16.04 machine) via same rosserial_server package's socket_node and it works just fine.

edit retag flag offensive close merge delete