How to remove Large wireframes of the meshes spawned using ros3d.js

asked 2020-02-15 06:12:17 -0500

_vishal145 gravatar image

updated 2020-02-15 09:29:01 -0500

gvdhoorn gravatar image


I've been utilizing the ros3d.js for visualization and interaction purposes.

One of the scenarios require the spawning multiple types of 3d objects like a primitive cube, custom gltf model, and even text geometry.

But whenever I add the meshes to the scene, I get large wireframes of the meshes spawned along with it. And it seems to interfere with the user experience.

I've attached a couple of images as reference as well.

spawned_object (text geometry),

spawned_wireframe (text geometry)

Would be thankful for any help provided.


edit retag flag offensive close merge delete


Looks like your meshes are just not correctly scaled. ROS uses SI units for everything, so scale for meshes should be metres. See also REP-103. Your meshes appear to be using millimetres.

gvdhoorn gravatar image gvdhoorn  ( 2020-02-15 06:34:24 -0500 )edit

And please attach your screenshots to the question directly instead of linking to imgur.

I've given you sufficient karma to do that.

gvdhoorn gravatar image gvdhoorn  ( 2020-02-15 06:35:05 -0500 )edit

many thanks for your response. actually i did try to scale down the mesh. but there's a wireframe of the mesh which remains in the same location, and looks way enlarged.

_vishal145 gravatar image _vishal145  ( 2020-02-15 08:06:54 -0500 )edit

Then I would suggest you check your mesh to make sure it doesn't actually contain multiple models. gltf supports this fi.

gvdhoorn gravatar image gvdhoorn  ( 2020-02-15 09:28:48 -0500 )edit

got it! let me experiment with supported model types then

_vishal145 gravatar image _vishal145  ( 2020-02-16 00:27:26 -0500 )edit