When running nav2_map_server "Magick: abort due to signal 11" [closed]

asked 2020-02-10 05:41:35 -0600

lorenzo gravatar image

I want to display a map on rviz2. In three different terminal I run rviz2, nav2_map_server and nav2_util.

In order I run the following terminals.

Terminal1:

lorenzoteo@lorenzoteo-HP-ZBook-15v-G5:~$ ros2 run rviz2 rviz2
[INFO] [rviz2]: Stereo is NOT SUPPORTED
[INFO] [rviz2]: OpenGl version: 3.1 (GLSL 1.4)
[INFO] [rviz2]: Stereo is NOT SUPPORTED

Terminal2:

lorenzoteo@lorenzoteo-HP-ZBook-15v-G5:~$ ros2 run nav2_util lifecycle_bringup map_server

Terminal3:

lorenzoteo@lorenzoteo-HP-ZBook-15v-G5:~$ ros2 run nav2_map_server map_server --ros-args --params-file /home/lorenzoteo/Downloads/map_server_params.yaml
[INFO] [map_server]: Creating
[INFO] [map_server]: Configuring
[INFO] [map_server]: OccGridLoader: Creating
[INFO] [map_server]: OccGridLoader: Configuring
[INFO] [map_server]: Activating
[INFO] [map_server]: OccGridLoader: Activating
Magick: abort due to signal 11 (SIGSEGV) "Segmentation Fault"...

As you can see when I run the nav2_map_server package I was thown by a segmentation fault. Any idea on how to solve?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by stevemacenski
close date 2020-02-10 10:58:01.359892

Comments

Given your other question, I assume you’ve fixed this?

stevemacenski gravatar imagestevemacenski ( 2020-02-10 10:02:25 -0600 )edit

Yes you are right

lorenzo gravatar imagelorenzo ( 2020-02-10 10:42:23 -0600 )edit