ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Ubuntu (slave) & Raspberry pi 4 (master) not able to connect

asked 2020-02-08 11:22:18 -0500

phil123456 gravatar image

updated 2020-02-09 10:04:34 -0500


I got some weird behaviour,

I setup the master uri to my other machine, and run roscore with no issue

but on the slave I get this

WARNING: ROS_MASTER_URI **[]** host is not set to this machine

auto-starting new master

process[master]: started with pid [3579]

ROS_MASTER_URI=**http://ros:11311/** <-------how do I fix this ????
  • I cannot list any service nor publisher from the master (but I can 'ping' and 'netcat 11311' it)

  • I tried editing the hosts file so 'ros' would point to the master instead of, but then roscore failed to launch

any idea what's could be wrong?


edit retag flag offensive close merge delete


anyone ? this looks like a bug, I have set ROS_IP and ROS_HOSTNAME to the local machine ip, still the same, roscore runs localy, but if I set these variables to the remote master ip, the roscore fails trying to contact it

phil123456 gravatar image phil123456  ( 2020-02-09 10:02:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2020-02-09 10:21:20 -0500

phil123456 gravatar image

updated 2020-02-09 10:21:39 -0500

stupid of me, only one roscore needs to run

seems obvious now but not from the multiple machines tutorial page

here is a better explanation on how to achieve multiple machines ROS :

edit flag offensive delete link more

Question Tools



Asked: 2020-02-08 11:22:18 -0500

Seen: 646 times

Last updated: Feb 09 '20