Ask Your Question
0

No message published to ROS Melodic from clearpath(Indigo)

asked 2020-02-05 16:08:44 -0500

thompson104 gravatar image

updated 2020-02-05 17:48:27 -0500

Currently we have a clearpath ridgeback running Ubuntu 14.04(Indigo) that is connected to a remote PC running Ubuntu 18.04 (Melodic).

Currently I'm able or not able to do the following:

1) running rostopic list on my remote PC, I'm able to see all the topics being published by ridgeback; However, I'm not able to rostopic echo any of the above topics on my remote PC. For example, when I run

rostopic echo -c tf

There is no response on my remote PC. However, if I run the same command on my ridgeback, I can see the tf topic is being printed out.

2) When I run rostopic echo $ANYTOPIC$ on my remote PC and run rostopic info $ANYTOPIC$ on the ridgeback, I can see there is a new subscriber created for my remote PC to subscribe $ANYTOPIC$;

3) I can publish info (simple rospy publisher tutorial) from my remote PC to the ridgeback robot and the ridgeback can successfully subscribe to it and print it out; The ridgeback can publish info and my remote PC is able to subscribe to it and print it out. The problems only exist for the topics that are being published at the start-up of ridgeback.

5) This problem doesn't happen until I upgraded my PC to Ubuntu 18.04.

Can anyone provide a few thoughts?

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-02-05 16:27:06 -0500

This looks like a classic ROS Networking issue that is described here: http://wiki.ros.org/ROS/NetworkSetup. Particularly look at ROS_IP and ROS_HOSTNAME.

I can't explain the upgrade to 18.04 off hand. Though I will say that there is 0 intent, testing, or support for mixing ROS distributions. If the networking support doesn't fix it, you should again move back to Indigo or upgrade your robot to Melodic

edit flag offensive delete link more

Comments

I don't think it is the IP and host name issues since my remote PC and clearpath robot is able to publish and subscribe to each other. The problems only happen to the topics that are launched at the start-up of the ridgeback robot. I wonder if you may have suggestions?

thompson104 gravatar image thompson104  ( 2020-02-05 17:48:55 -0500 )edit

The problems only happen to the topics that are launched at the start-up of the ridgeback robot

there is a good chance this is caused by the fact that for those nodes (topics are not "launched", only nodes are), the ROS_IP and related variables don't have the correct values (or perhaps are not set).

gvdhoorn gravatar image gvdhoorn  ( 2020-02-06 02:53:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-02-05 16:08:44 -0500

Seen: 17 times

Last updated: Feb 05