Ask Your Question
0

receiving transform from [/robot_state_publisher] that differed from ROS time

asked 2020-02-03 12:33:52 -0500

arafatsadasd gravatar image

updated 2020-02-10 04:06:50 -0500

Hello ALL I'm beginner to ros

I have mounted zed camera on my youBot robot and connected the tf tree as follows:

image description

when I visualize in rviz the camera only works when I choose the arm_link_5 or base_link_zed and its children as fixed frame and I want it to work when using odom as fixed frame since I have a linked tf tree.

image description

when running roswtf i get:

receiving transform from [/robot_state_publisher] that differed from ROS time by 566050.175641s

so is the problem with the transfer frequency and if so how can i fix it?

edit retag flag offensive close merge delete

Comments

Could you check your screenshots? You didn't have enough karma before, so they were never attached.

gvdhoorn gravatar image gvdhoorn  ( 2020-02-04 08:11:09 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-02-24 11:56:24 -0500

arafatsadasd gravatar image

fixed it by synchronising the time.

edit flag offensive delete link more

Comments

can you please be more specific? How did you synchronize the time?

Gates gravatar image Gates  ( 2021-09-01 08:40:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-02-03 12:32:58 -0500

Seen: 202 times

Last updated: Feb 24 '20