Issues regarding map_server

asked 2020-02-03 03:23:45 -0500

Nitin_J gravatar image

updated 2020-02-03 03:25:00 -0500

Hello all, I am facing a startup issue with the map_server. I am trying to setup this on a Nvidia Jetson Nano board, though the same setup is working on a Raspberry Pi 3B+ board. For Jetson, it's diving into certain issues, I resolved many but unable to resolve these ones. I am attaching the relevant output from the terminal which I get when I run the project.

setting /run_id to ac921624-465e-11ea-854a-00044be541e0
process[rosout-1]: started with pid [7295]
started core service [/rosout]
process[robot2/base_to_lidar-2]: started with pid [7302]
process[robot2/base_to_sonar-3]: started with pid [7303]
process[robot2/base_controller_node-4]: started with pid [7304]
process[robot2/motor_driver_node-5]: started with pid [7315]

process[robot2/tcp_server_node-7]: started with pid [7317]
process[robot2/rplidarNode-8]: started with pid [7327]
process[robot2/laser_filter-9]: started with pid [7334]
[ INFO] [1580718307.096068066]: RPLIDAR running on ROS package rplidar_ros. SDK Version:1.12.0
process[robot2/robot_controller_node-10]: started with pid [7339]
process[robot2/nodelet_manager-11]: started with pid [7345]
process[robot2/velocity_smoother-12]: started with pid [7352]
process[map_server-13]: started with pid [7354]
[ INFO] [1580718307.343979394]: BOX filter started
[ INFO] [1580718307.346575962]: invert filter not set, assuming false
process[robot2/move_base-14]: started with pid [7360]
[ WARN] [1580718307.403541579]: Using deprecated map server interface. Please switch to new interface.
process[robot2/r2amcl-15]: started with pid [7379]
[ INFO] [1580718307.892212943]: Subscribed to map topic.
[ INFO] [1580718308.181643986]: Received a 1984 X 1984 map @ 0.050 m/pix

[ WARN] [1580718308.181778845]: Frame_id of map received:'/map' doesn't match global_frame_id:'map'. This could cause issues with reading published topics
[ INFO] [1580718308.544700222]: Initializing likelihood field model; this can take some time on large maps...
[ INFO] [1580718309.012177912]: Done initializing likelihood field model.
RPLIDAR S/N: 55BC9AF2C1EA9FC0A2EB92F1C66F3C02
[ INFO] [1580718309.609679209]: Firmware Ver: 1.25
[ INFO] [1580718309.609777657]: Hardware Rev: 5
[ INFO] [1580718309.611322563]: RPLidar health status : 0
[ INFO] [1580718310.156915537]: current scan mode: Express, max_distance: 12.0 m, Point number: 4.0K , angle_compensate: 1
[ WARN] [1580718312.843989564]: Timed out waiting for transform from base_link to = /map to become available before running costmap, tf error: canTransform: target_frame = /map does not exist. canTransform: source_frame base_link does not exist.. canTransform returned after 0.100096 timeout was 0.1.
[ WARN] [1580718317.879287019]: Timed out waiting for transform from base_link to = /map to become available before running costmap, tf error: canTransform: target_frame = /map does not exist. canTransform: source_frame base_link does not exist.. canTransform returned after 0.10097 timeout was 0.1.

The below statement:

[ WARN] [1580541492.073914543]: Timed out waiting for transform from base_link to = map to become available before running costmap, tf error: canTransform: target_frame = map does not exist. canTransform: source_frame base_link does not exist.. canTransform returned after 0.101147 timeout was 0.1.

keeps on continually printing to the terminal until I kill the process.

Specifications for the system am using:-

CPU & Processor  >  Nvidia Jetson Nano
OS  > Ubuntu 18.04.4 LTS
Codename  >  bionic
ros-distro  >  melodic

Relevant packages :

  1. navigation > https://github.com/ros-planning/navigation
edit retag flag offensive close merge delete